All windows are treated as private when 'never remember history' is set

RESOLVED DUPLICATE of bug 841821

Status

Add-on SDK
General
P2
normal
RESOLVED DUPLICATE of bug 841821
5 years ago
4 years ago

People

(Reporter: erikvold, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

See details here https://bugzilla.mozilla.org/show_bug.cgi?id=874554#c7

"We had the report of a user setting "never remember history" in settings panel. What it actually does is to always be in private mode!!! With such option toggled, your menuitems library is completely disabled, as it relies on WindowTracker :/
The only way out of this is to give private-browsing permission to the addon."
It looks like this was intentional.. I never knew this was going to happen.  Ehsan told us not to implement anything resembling global private browsing mode and that is exactly what appears to have been done on the platform, as a restart is required to set 'never remember history' and after you've done so you can only open private windows..

What really sucks because of this is that user with 'never remember history' turned on will suddenly have add-ons that completely stop working with no indication why that is..
Flags: needinfo?(ehsan)
I think the best solution may be to just get bug 841821 done.

Any other ideas?
Depends on: 841821

Comment 3

5 years ago
Never remember history makes all windows private.  I think I brought up the fact that the add-ons don't work with some of the windows but work with others as a problem back when we were discussing the solution and somebody (don't remember who) convinced me that it's ok...
Flags: needinfo?(ehsan)
Ehsan, do we know from telemetry/FHR how many users have 'never remember history' set?
Flags: needinfo?(ehsan)
Priority: -- → P2

Comment 5

5 years ago
You should ask those folks.  I don't know of any such information.
Flags: needinfo?(ehsan)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 841821
You need to log in before you can comment on or make changes to this bug.