As much as I admire the adherence to tradition here, I think it would be more consistent (and therefore less surprising) if the CSRCS variable was named C_SOURCES in line with CPP_SOURCES.
Taking the liberty to morph this based on what one actually wants! (see bug 864774 comment 48)
Even better. Thanks, ehsan.