Closed Bug 877953 Opened 8 years ago Closed 8 years ago

Intermittent test_cached_messages.html | number of cached page errors - got n, expected 2

Categories

(DevTools :: Console, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 24

People

(Reporter: philor, Assigned: msucan)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #802013 +++

Not sure how long this has been busted, because we've been marking runs with mochitest-chrome failures as green for at least a day, if not since last Saturday.

https://tbpl.mozilla.org/php/getParsedLog.php?id=23622680&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test mochitest-other on 2013-05-30 19:16:54 PDT for push db7a405f0a45
slave: talos-r4-snow-040

19:33:48     INFO -  31543 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/devtools/webconsole/test/test_cached_messages.html | actor: /[a-z]/ matched conn4.obj10
19:33:48     INFO -  --DOMWINDOW == 36 (0x14eadef30) [serial = 3423] [outer = 0x0] [url = http://mochi.test:8888/chrome/toolkit/devtools/server/tests/mochitest/nonchrome_unsafeDereference.html]
19:33:48     INFO -  31544 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/devtools/webconsole/test/test_cached_messages.html | expected uncaught exception - TypeError: document.doTheImpossible is not a function at chrome://mochitests/content/chrome/toolkit/devtools/webconsole/test/test_cached_messages.html:0
19:33:48     INFO -  JavaScript error: chrome://mochitests/content/chrome/toolkit/devtools/webconsole/test/test_cached_messages.html, line 0: document.doTheImpossible is not a function
19:33:48     INFO -  OS Agent Received message {"fun":"writeAtomic","args":[{"string":"/var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/tmpICgHKK/sessionstore.js"},{"ptr":"5621127696"},{"tmpPath":{"string":"/var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/tmpICgHKK/sessionstore.js.tmp"},"bytes":72167}],"id":266}
19:33:48     INFO -  OS Agent Calling method writeAtomic
19:33:48     INFO -  OS Agent Method writeAtomic succeeded
19:33:48     INFO -  OS Agent Sending positive reply 72167 id is 266
19:33:48     INFO -  WARNING: NS_ENSURE_TRUE(scrollFrame) failed: file ../../../dom/base/nsDOMWindowUtils.cpp, line 1534
19:33:49     INFO -  31545 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/devtools/webconsole/test/test_cached_messages.html | number of cached page errors - got 11, expected 2
Summary: Intermittent test_cached_messages.html | number of cached page errors - got 11, expected 2 → Intermittent test_cached_messages.html | number of cached page errors - got n, expected 2
Was this caused by bug 859756? Can you take a look? :-)
Flags: needinfo?(mihai.sucan)
(In reply to Ed Morley [:edmorley UTC+1] from comment #38)
> Was this caused by bug 859756? Can you take a look? :-)

I am not sure yet. I had try runs for that patch and they were green...

This bug is in my TODO list to investigate and to write a patch for. I will take a look as soon as possible.
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
Flags: needinfo?(mihai.sucan)
(In reply to Mihai Sucan [:msucan] from comment #42)
> This bug is in my TODO list to investigate and to write a patch for. I will
> take a look as soon as possible.

Thank you :-)
Blocks: 878578
Attached patch proposed fixSplinter Review
These failures look like we are getting unexpected nsiconsolemessages being logged while the test runs - even if the test clears the nsiconsoleservice store.

The same problem seems to happen in bug 878578.

This patch changes the two tests to allow for unexpected messages to be received, as long as we also get the messages we want.

Try push: https://tbpl.mozilla.org/?tree=Try&rev=f426cec1eaa2

r=me
(In reply to Mihai Sucan [:msucan] from comment #59)
> Created attachment 758102 [details] [diff] [review]
> proposed fix
> 
> These failures look like we are getting unexpected nsiconsolemessages being
> logged while the test runs - even if the test clears the nsiconsoleservice
> store.
> 
> The same problem seems to happen in bug 878578.
> 
> This patch changes the two tests to allow for unexpected messages to be
> received, as long as we also get the messages we want.
> 
> Try push: https://tbpl.mozilla.org/?tree=Try&rev=f426cec1eaa2
> 
> r=me

The try push looks ok to me - happy for this to land? :-)
Flags: needinfo?(mihai.sucan)
(In reply to Ed Morley [:edmorley UTC+1] from comment #88)
> The try push looks ok to me - happy for this to land? :-)

Yes!

Landed: https://hg.mozilla.org/integration/mozilla-inbound/rev/151ae3dcc6b0

(sorry, yesterday I was offline)
Flags: needinfo?(mihai.sucan)
No problem - thank you for fixing this! :-)
https://hg.mozilla.org/mozilla-central/rev/151ae3dcc6b0
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.