If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Update FTE to include geolocation notice

RESOLVED FIXED

Status

Firefox OS
Gaia::First Time Experience
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

unspecified
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

(URL)

Attachments

(3 attachments)

(Assignee)

Description

4 years ago
FTE must include notice to user that Gelocation Location Services will send data to a 3rd party




"Use additional location services

Firefox OS uses data such as WiFi and mobile networks near you to help your device determine your approximate location more quickly and in places where GPS is not available. I recommend the box be checked.

[X] Enable additional location services.

Data is sent to Mozilla and other service providers and will be used in the aggregate to improve those location databases. Data may be stored on your device and data collection may occur even when no apps are running.
(Assignee)

Comment 1

4 years ago
required for enabling geolocation services on 1.1
blocking-b2g: --- → leo?
(Assignee)

Comment 2

4 years ago
Created attachment 756381 [details] [diff] [review]
patch v.1
Assignee: nobody → doug.turner
Attachment #756381 - Flags: review?(fabrice)
Attachment #756381 - Flags: review?(fabrice) → review+
blocking-b2g: leo? → leo+
(Assignee)

Comment 3

4 years ago
Created attachment 756434 [details] [diff] [review]
default pref to checked
Attachment #756434 - Flags: review?(fabrice)
(Assignee)

Comment 4

4 years ago
sorry missed this second patch - we want to default it to checked like we had it before.
Attachment #756434 - Flags: review?(fabrice) → review+
https://github.com/mozilla-b2g/gaia/commit/d29032e263c99842cd17dbd9a4d5be0117e770e4
https://github.com/mozilla-b2g/gaia/commit/640539e5a7918bff2034a6dc3ab4e2d43ff19b64
This is causing a little regression on FTU UX, the last step marker is out of the screen. 
Sending a quick patch in couple of minutes, you can add it in here directly or open a followup
Created attachment 756612 [details] [diff] [review]
UX fix
Attachment #756612 - Flags: review?(fabrice)
Comment on attachment 756612 [details] [diff] [review]
UX fix

Review of attachment 756612 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Fernando. Feel free to push that to master.
Attachment #756612 - Flags: review?(fabrice) → review+
merged on master: https://github.com/mozilla-b2g/gaia/commit/d0e0de3a35fecffd1f0d1cbd01ebae2a1cfc373a

Should we close the bug or is there something still pending?
We can close it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Uplifted d0e0de3a35fecffd1f0d1cbd01ebae2a1cfc373a to:
v1-train: c6bde0a88c6ff2a0bfe25db2d188abf9c1c89eb6
status-b2g18: --- → fixed

Updated

4 years ago
Flags: in-moztrap?

Updated

4 years ago
Flags: in-moztrap? → in-moztrap+
QA Contact: amiller
Two questions/notes about the strings added in this bug.

geolocationInfo = Firefox OS uses data such as GPS, WiFi, and mobile networks near you to help determine your approximate location.

1) You should clearly use "Wi-Fi" instead of "WiFi", since that's the standard in all existing en-US strings.
2) Why hard-coding "Firefox OS" when all other strings in ftu.properties use "{{brandShortName}}"?

Let me know if you want me to open a new bug depending on this.
Blocks: 880597
(Assignee)

Comment 13

4 years ago
Yes, this bug is fixed.  new bugs are cheap. please open new ones. :)
Blocks: 880710
You need to log in before you can comment on or make changes to this bug.