translate.google.com - source html tags converted to capital letters

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: Arthur, Assigned: Amit J. Patel)

Tracking

Details

(Whiteboard: aok, URL)

(Reporter)

Description

17 years ago
1. Go to the URL above
2. look at the source of the frame with the translation (right click, view frame
source)
3. Choose "save as" in the source window
4. Reopen the saved file with a text editor

Result:
All html tags are converted to capital letters (which is against xhtml-rules)

Expected Result:
Not converted tags

I know that the code isn't perfect but it's still a strange behaviour.
(Reporter)

Comment 1

17 years ago
Hm, by the way: I'm using Linux build 2001062421. ( I'm sure the bugzilla form
asked something like "linux build ... is this correct?" but it didn't find it's
way into the bugreport... )

Comment 2

17 years ago
this is not mozilla's fault. the translator is doing it.  Since we do have some 
google contacts, i'm giving them the bug.  They may choose to resolve wontfix, 
but before marking invalid they would have to move this out of the evangelism 
component because that component forbids that resolution.
Assignee: asa → amitp
Component: Browser-General → Evangelism
Summary: Source html tags converted to capital letters → translate.google.com Source html tags converted to capital letters
(Reporter)

Comment 3

17 years ago
No, the translator doesn't do it. In the source window, the tags appear
lowercase. Only when I save it, they get converted to uppercase (or can google
influence the way the browser saves things?).

Comment 4

17 years ago
Aren't the tags that show up in the source window created by CSS rules?  I don't
think they're necessarily the same case as the tags in the document.  If that's
true, then the uppercasing probably is coming from the translator, and just not
showing up in the source window because our view source maps everything to
lowercase.  Who's the expert on browser View Source these days?

Comment 5

17 years ago
this isn't fair. when i test things I use telnet or netscape4. I can assure you 
that the view-source: output I got was from netscape4 and had uppercase tags. 
Mozilla was _not_ interfering w/ the output.

this is the url i loaded w/ nc4:
view-source:http://translate.google.com/translate_c?hl=en&sl=de&u=http://www.si
teware.ch/digichat/

I can open the same url w/ notepad if you feel a need for me to waste my time. 
warning, to load the url w/ notepad, you need to use 
http://translate.google.com/translate_c?hl=en&sl=de&u=http://www.siteware.ch/di
gichat/index.html [and w2k or better, it's an os feature]

Ooh, so the parser is making the characters lowercase in mozilla? wonderful 
just what i needed.  FWIW My decision stands this bug is against google. If the 
parser people don't already have a bug they can file one, but i'm sure we know 
that view-source in mozilla doesn't view raw source :(.
Status: UNCONFIRMED → NEW
Ever confirmed: true
View Source lowercases tags.  There's a bug on this already (bug 63137).  I may
not be an expert, but I've spent a few dozen hours in that code....  :)  This is
correctly assigned to evangelism.
(Reporter)

Comment 7

17 years ago
I don't mind if google converts tags to uppercase, even if it's wrong. My
problem is, that I don't get saved what I see in the source and that I don't see
what I've got from the server. To me it's ok if this gets marked as a duplicate
of bug 63137 .

Comment 8

17 years ago
reporter: i'm sorry, i can't remove you as the reporter, even though bugzilla 
allows you to control wether it sends you notification of such an event. This 
bug remains as is.

Comment 9

17 years ago
taking QA, someone at google will report this issue to the people who wrote the 
engine, "but it's unlikely to be fixed anytime soon."
Status: NEW → ASSIGNED
QA Contact: doronr → timeless
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Updated

17 years ago
Whiteboard: aok
Keywords: evang500
looks fixed on win2k, since this was an issue on  google, marking fixed. Please
reopen if you disagree.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

16 years ago
Verified
2002040303/WinXP
Status: RESOLVED → VERIFIED
Summary: translate.google.com Source html tags converted to capital letters → translate.google.com - source html tags converted to capital letters
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.