[Settings] WiFi networks list broken

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gerard, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
E/GeckoConsole(  432): [JavaScript Error: "NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "network is null" {file: "app://settings.gaiamobile.org/js/wifi.js" line: 393}]' when calling method: [nsIDOMEventListener::handleEvent]" {file: "jar:file:///system/b2g/omni.ja!/components/DOMWifiManager.js" line: 302}]
(Reporter)

Comment 1

5 years ago
Looks like the network might sometime not be set.
(Reporter)

Comment 2

5 years ago
Created attachment 756456 [details]
Link to Github https://github.com/mozilla-b2g/gaia/pull/10127

Please find attached a link to the Github pull request #10127 https://github.com/mozilla-b2g/gaia/pull/10127
Attachment #756456 - Flags: review?(kaze)
Good catch, thanks! Merged on master: https://github.com/mozilla-b2g/gaia/commit/6a0b2e542f3f4fd042798ab2bd0c21df523e94a4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
FTR, this regression was caused by bug 816135 — which I reviewed too fast, obviously.
Depends on: 816135
Uplifted to v1-train together with Bug 816135 on commit 240c1d2f87b86f6f6dd21d8549081e26b542f0cc
status-b2g18: --- → fixed

Updated

5 years ago
blocking-b2g: leo? → leo+

Updated

5 years ago
Flags: in-moztrap-
Comment on attachment 756456 [details]
Link to Github https://github.com/mozilla-b2g/gaia/pull/10127

Ooops, forgot to r+ the patch when I merged it…
Attachment #756456 - Flags: review?(kaze) → review+

Comment 7

5 years ago
Issue no longer repros on the Leo device.
Build ID: 20130807071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/11bb1b0eefff
Gaia: 60ca81600a080dae33058b0692ecaa213556c926
Platform Version: 18.1

WiFi networks lists show n as expected with the WiFi signal.
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.