Last Comment Bug 878058 - Bottom padding missing inside fixed and scrolled elements
: Bottom padding missing inside fixed and scrolled elements
Status: RESOLVED DUPLICATE of bug 748518
:
Product: Core
Classification: Components
Component: Layout: Block and Inline (show other bugs)
: 21 Branch
: All All
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 07:41 PDT by silverwind
Modified: 2014-01-16 08:22 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Example (506 bytes, text/html)
2013-05-31 07:41 PDT, silverwind
no flags Details

Description User image silverwind 2013-05-31 07:41:51 PDT
Created attachment 756566 [details]
Example

See attached example.

The element in question has position: fixed; padding: 50px. When such a element is scrolled, the scrolled area seems to ignore the bottom padding and stops where the content ends. Same example works fine in Chrome.

Might be related to bug 458296.
Comment 1 User image Boris Zbarsky [:bz] (still a bit busy) 2013-05-31 10:30:23 PDT
> the scrolled area seems to ignore the bottom padding and stops where the content ends.

Yes, that's the behavior the CSS spec requires.  WebKit has a long-standing bug in that regard, which is why you see a different behavior in Chrome.
Comment 2 User image Mats Palmgren (:mats) 2013-05-31 13:41:59 PDT

*** This bug has been marked as a duplicate of bug 748518 ***
Comment 3 User image silverwind 2013-05-31 16:16:16 PDT
Thanks for clearing this up. This behavior really feels "wrong" to me, but should be easy enough to work around.

Note You need to log in before you can comment on or make changes to this bug.