Browser Cookies are not set in the HTTP header when JAVA applet performs URLConnection request

VERIFIED DUPLICATE of bug 85827

Status

--
critical
VERIFIED DUPLICATE of bug 85827
18 years ago
8 years ago

People

(Reporter: bcortez, Assigned: edburns)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Mozilla Build: 2001062504

Browser Cookies are not set in the HTTP header when JAVA applet performs 
URLConnection request.  When pages are requested directly by the browser, the 
cookies are set in the HTTP header and sent to the server.  However, when an 
applet withing a <APPLET> tag makes a URLConnection request for a page, the 
associated browser cookies are not set in the HTTP header.  This results in the 
server not receiving the necessary browser cookies. 

When a sessionid cookie is used to track the user's authenticated session, this 
bug causes the server to invalidate the request as coming from the same browser 
session (which in fact is incorrect).
(Reporter)

Comment 1

18 years ago
Additional note: This bug has the exact same behavior as bug 87024 (fixed).  
However, this bug applies to the JAVA applet making the request for the HTML 
page and not the browser itself.
Duplicate of "Java plugin do not use or is unable to accept cookies"

*** This bug has been marked as a duplicate of 85827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
SPAM: reassigning OJI bugs to new QA, pmac. (227 bugs)
QA Contact: shrir → pmac

Comment 4

18 years ago
Verified dup.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.