Last Comment Bug 878062 - 40MB AWSY regression on May 31
: 40MB AWSY regression on May 31
Status: RESOLVED FIXED
[MemShrink]
:
Product: Core
Classification: Components
Component: Graphics: Layers (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla24
Assigned To: Joe Drew (not getting mail)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks: 867770
  Show dependency treegraph
 
Reported: 2013-05-31 07:49 PDT by Timvde
Modified: 2013-06-13 00:06 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
don't TryOptimizeToImageLayer() if the optimization is disabled (4.00 KB, patch)
2013-05-31 14:25 PDT, Joe Drew (not getting mail)
matt.woodrow: review+
Details | Diff | Splinter Review

Description Timvde 2013-05-31 07:49:35 PDT
It looks like bug 867770 introduced a regression of about 40MB on AWSY after TP5, before closing the tabs. The misc graph shows almost all of the lost memory in heap-unclassified.
Comment 1 Joe Drew (not getting mail) 2013-05-31 14:25:37 PDT
Created attachment 756783 [details] [diff] [review]
don't TryOptimizeToImageLayer() if the optimization is disabled

This should fix the bug, though I still need to verify that on AWSY. We were always optimizing background images to image layers, which we know will cause more memory use—which is the reason for the pref I added in the first place, actually.

https://tbpl.mozilla.org/?tree=Try&rev=143458b5a910
Comment 2 Joe Drew (not getting mail) 2013-05-31 14:26:30 PDT
BTW: Is there a bug on Image* (ImageLayer, ImageContainer, Image) not reporting their sizes?
Comment 3 Andrew McCreight [:mccr8] 2013-06-02 20:03:03 PDT
Hey John, could you annotate AWSY with the bug number of this regression?  Or the regressor, I guess.  Thanks.
Comment 4 Andrew McCreight [:mccr8] 2013-06-02 20:03:53 PDT
Thanks for quickly investigating and patching this regression, Joe!
Comment 5 Joe Drew (not getting mail) 2013-06-03 07:58:04 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2ff8cbefdf10

I'm running this on AWSY, but it is unlikely to make things *worse* so I've pushed it too.
Comment 6 Joe Drew (not getting mail) 2013-06-03 11:06:34 PDT
This seems to have fixed the regression.
Comment 7 John Schoenick [:johns] 2013-06-03 11:30:28 PDT
Annotated on AWSY:
https://github.com/Nephyrin/MozAreWeSlimYet/commit/2c282f6
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-06-03 13:04:01 PDT
https://hg.mozilla.org/mozilla-central/rev/2ff8cbefdf10

Note You need to log in before you can comment on or make changes to this bug.