Closed Bug 878063 Opened 11 years ago Closed 6 years ago

Deleting a whole site from the history stops all downloads

Categories

(Toolkit :: Data Sanitization, defect)

21 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 603239

People

(Reporter: gezet.news, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

I have several files being downloaded within firefox (the actual number doesn't matter).

Open history (CTRL+H). Choose a site that you visited very often and right click it. Choose "Forget whole website" (I don't have an english interface, so the entry might be similar to that, sorry! - Anyway it's the last item in the pop-up menu).


Actual results:

The spinner starts spinning for several minutes (5 or 6 in my case). FF does not accept any user interaction during this time. This also causes the downloads to time out, so they have to be started again afterwards.


Expected results:

The website should be deleted in the background, with user interaction possible in the meantime. Downloads should continue during this time.
Component: Untriaged → Places
Product: Firefox → Toolkit
the problem is that "Forget About This Site" tries to remove any data about that page, among that data there are the cache and plugins data, that are known to cause slowdowns.
This is likely not an history bug.
Component: Places → Forget About Site
So this depends on Bug 699850/Bug 648232 and Friends?
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.