Android |make install| message is misleading when no devices are connected

RESOLVED FIXED in mozilla24

Status

Firefox Build System
General
RESOLVED FIXED
5 years ago
4 months ago

People

(Reporter: nalexander, Assigned: nalexander)

Tracking

unspecified
mozilla24
All
Android

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
This has pissed me off for the last time!  Also, it confuses new contributors.
(Assignee)

Comment 1

5 years ago
Created attachment 756587 [details] [diff] [review]
Clarify |make install| message when no Android devices are connected. r=ted
Attachment #756587 - Flags: review?(ted)
Comment on attachment 756587 [details] [diff] [review]
Clarify |make install| message when no Android devices are connected. r=ted

Review of attachment 756587 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/build.mk
@@ +30,1 @@
>  ifneq ($(android_devices),device)

This is a little weird, because both of these conditionals will be true if there are no devices connected. I think wrapping this second conditional in an else/endif would be clearer.
Attachment #756587 - Flags: review?(ted) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a6d08264b017
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla24
https://hg.mozilla.org/mozilla-central/rev/a6d08264b017
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

4 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.