[meta] GC: Call JS_IsAboutToBeFinalized on weak CC participant edges

RESOLVED DUPLICATE of bug 650161

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 650161
5 years ago
3 years ago

People

(Reporter: terrence, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Updated

5 years ago
Depends on: 877924
(Reporter)

Updated

4 years ago
Blocks: 1008341
No longer blocks: 764882
(Reporter)

Comment 1

4 years ago
Regarding the purpose of this bug, which I should have expanded upon when filing initially: for moving GC, we must tell the GC about all edges in every GC. Older code in SpiderMonkey was in the habit of not marking some edges when another edge was known to have been marked. If we do this now, however, we'll end up not updating a moved edge.

At this point, we're fairly certain we have verified that we mark all strong and weak edges in SpiderMonkey and all strong edges in Gecko. I don't think there is a specific problem with Gecko not tracing some weak edges, but I want to dive into the weakmap marking code in gecko and verify manually anyway. Just haven't had time yet.
(Assignee)

Updated

4 years ago
Assignee: general → nobody
(Reporter)

Updated

3 years ago
No longer depends on: 877924
(Reporter)

Comment 2

3 years ago
This getting done naturally as part of the shakeout in getting compacting GC operational.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 877924
Resolution: --- → DUPLICATE
Duplicate of bug: 650161
(Reporter)

Comment 3

3 years ago
Thanks bugzilla!
No longer depends on: 877924
You need to log in before you can comment on or make changes to this bug.