Add prompt for airplane mode

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
8 months ago

People

(Reporter: jcarpenter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Per bug #876597, we need to add a prompt to the FM Radio when in the device is in Airplane Mode. This prompt should be similar to the "Must plug in your headphones" prompt that appears when the user opens the app without first plugging in headphones. 

The strings should be along the lines of:

Title: Airplane mode is on.
Body: Turn off Airplane mode to use FM Radio.
Button: Cancel (closes app and returns user to Home app)
I actually do see the prompt on 1.3 .

There's no cancel button, although the no-headphones warning has no cancel button either.

Should this be marked as resolved?
We didn't have a good solution for the cancel button when fixing bug 876597 (https://bugzilla.mozilla.org/show_bug.cgi?id=876597#c40). This bug was opened for tracking the not-finished button.
Is there anything I can help with? And would this be good as an almost-first contribution? (I already tried contributing to gaia, but it was just modifying strings)
Feel free to work on this bug. :)

Note that the problem is not adding a cancel problem. The problem is that when you click on the cancel button and call to window.close(), there is a undesired affect. I haven't tried this on the latest gecko, it might get fixed already.
Ok, I took a look at bug 876597's history. My impression is that there should not be a Cancel button, since it's not present in the headphones detection screen either.

If you look at this comment https://bugzilla.mozilla.org/show_bug.cgi?id=876597#c42 Josh himself is ok with the fact that the current implementation is consistent with the other screen. This bug was created after that comment, so shouldn't this bug be marked as WONTFIX?
(In reply to Federico 'klez' Culloca from comment #5)
> This bug was created after that comment, so shouldn't this bug be
> marked as WONTFIX?

s/before/after/
(In reply to Federico 'klez' Culloca from comment #5)
> This bug was created after that comment, so shouldn't this bug be
> marked as WONTFIX?
 
s/after/before/

Sorry, I'm tired

Comment 8

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.