If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Music] Music is playing in full blast volume after adding just one unit up

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System::Audio Mgmt
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

168.30 KB, text/plain
Details
(Reporter)

Description

4 years ago
Description:
After launching music app with previously muted sound and then adding one unit volume up, the song is playing in full blast sound

Repro Steps:
1) Updated to Inari Build ID: 20130531070205
2) Set the volume to mute using the hardware volume rocker (hardware buttons)
3) Open "Music" app from the home menu
4) Launch any song
5) Hit the volume up button once.

Actual:
The music in full blast volume

Expected:
The volume increases on one unit 

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/4f318822e72c
Gaia: e1c59baed29e4665d1da9392f86239272073f07a

Notes:
Repro frequency: 100%
Tested on "Inari" and "Unagi"
This issue reproduces only for the first time when the music application is launched or after booting the device
The issue doesn't reproduce if the application runs in next time

Environmental  Variables:
Inari Build ID: 20130531070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/be5c2ee11d02
Gaia: e7114bdf4078274fc127a3b2a58dad91d6884219

Environmental  Variables:
Unagi Build ID: 20130531070205
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/4f318822e72c
Gaia: e1c59baed29e4665d1da9392f86239272073f07a
(Reporter)

Updated

4 years ago
Blocks: 868932
(Reporter)

Comment 1

4 years ago
The same issue with calling sound control, when receiving a phone call on the device with muted sound. By clicking only once on "+" button, the sound in full blast

Environmental  Variables:
Unagi Build ID: 20130604070205
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/997cdbf5d012
Gaia: 5534304aee934055f08f21ce93261ba2a596516a

Inari Build ID: 20130604070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/42555e1e72fa
Gaia: bf10abc41a01516995a99f3c6727a612bbdfe755
(Reporter)

Comment 2

4 years ago
Created attachment 758281 [details]
logfile
(Reporter)

Comment 3

4 years ago
The issue still reproduces, after muting the volume (hardware volume button) and then launching the "Audio" app, the music is muted, but when clicking once on "+" hardware button" the music plays in full blast

Environmental  Variables:
Build ID: 20130726070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d6e518d3ef28
Gaia: 9c868050bcc6f522f54f4afc0f0e4aa9a6149771
Platform Version: 18.1

Comment 4

2 years ago
Based on comment 1, this isn't just a music bug. It might also be fixed already, so adding qawanted.
Component: Gaia::Music → Gaia::System::Audio Mgmt
Keywords: qawanted
Currently there is bug 1210955 where it would not show volume progress bar when adjusting volume. But I can hear that this issue is NOT reproducing, and that volume increases one step at a time when I increase it in Music app from muted state.

Device: Aries 2.5
BuildID: 20151007142909
Gaia: 77d463a009a1425e413edaae92b237e116708560
Gecko: 263526a3368d6e94f31ff526b9f5beba46f56347
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.5 (319MB memory)
BuildID: 20151007030237
Gaia: 77d463a009a1425e413edaae92b237e116708560
Gecko: d1c5a7c5b4331ee9ea5443de893fcfd0a5b80e2a
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

------

This bug is NOT reproducing on Flame 2.2 either. Without bug 1210955 I was able to visually see and hear volume increase one step at a time.

Device: Flame 2.2 (319MB memory)
BuildID: 20151006032504
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: fc588eb28eab
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Closing bug as works for me.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.