Stop "button" on address bar does not work majority of time

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: donrhummy, Unassigned)

Tracking

22 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Opened a page that partially loaded but continued to load other items. Clicked on the "X" on the right of the addressbar.


Actual results:

It opened up the address bar screen as though I had clicked the addressbar. I retried many, many times clicking further and further to the right until I was no longer on the addressbar, but it still did not work.


Expected results:

It should have stopped loading.

I believe this is due to it being on a phone and Firefox having an issue with small clickable areas. But if that's the case, the button needs to be made larger so Firefox can correctly interpret the click.

Using:
Firefox Beta
Nexus 4
I tried to reproduce this visiting a handful of sites on two devices and each time I successfully stopped a page in-load by hitting the 'x' button. Works for me; HTC One (Android 4.2), Galaxy S4 (Android 4.2). Can you enable 'show touches' in the Android developer options and grab a screen-capture of where you are hitting?
(Reporter)

Comment 2

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #1)
> I tried to reproduce this visiting a handful of sites on two devices and
> each time I successfully stopped a page in-load by hitting the 'x' button.
> Works for me; HTC One (Android 4.2), Galaxy S4 (Android 4.2). Can you enable
> 'show touches' in the Android developer options and grab a screen-capture of
> where you are hitting?

I turned on "show touches" but the touch disappears too quickly as Firefox draws over it (or maybe it just disappears on its own?) by expanding the address bar. But I can clearly see the bluw circle is over the "X" for a split second before it expands.
(Reporter)

Comment 3

5 years ago
(In reply to donrhummy from comment #2)
> (In reply to Aaron Train [:aaronmt] from comment #1)
> > I tried to reproduce this visiting a handful of sites on two devices and
> > each time I successfully stopped a page in-load by hitting the 'x' button.
> > Works for me; HTC One (Android 4.2), Galaxy S4 (Android 4.2). Can you enable
> > 'show touches' in the Android developer options and grab a screen-capture of
> > where you are hitting?
> 
> I turned on "show touches" but the touch disappears too quickly as Firefox
> draws over it (or maybe it just disappears on its own?) by expanding the
> address bar. But I can clearly see the bluw circle is over the "X" for a
> split second before it expands.

(I meant "blue" circle)

I just repeated it and this time the blue circle was over the middle and lower right of the "X" and it still opened the addressbar.

Comment 4

5 years ago
I am also experiencing the same problem in my Galaxy S4. To tap the stop button, I have to be very precise, otherwise the app will see it as if I am trying to tap on the URL bar.

It doesn't happen to Chrome.

This may be a duplicate: https://bugzilla.mozilla.org/show_bug.cgi?id=878382

Comment 5

4 years ago
(In reply to bakpao from comment #4)
> I am also experiencing the same problem in my Galaxy S4. To tap the stop
> button, I have to be very precise, otherwise the app will see it as if I am
> trying to tap on the URL bar.
> 
> It doesn't happen to Chrome.
> 
> This may be a duplicate: https://bugzilla.mozilla.org/show_bug.cgi?id=878382

I tried it again in the latest version and it does not happen anymore.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.