Closed Bug 878291 Opened 7 years ago Closed 7 years ago

PJS: ParallelArray functionality is not compiled into shells anymore

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla24
Tracking Status
firefox23 --- fixed
firefox24 --- fixed

People

(Reporter: nmatsakis, Assigned: Gavin)

References

Details

Attachments

(1 file)

Bug 875342 changed the Makefile.in logic so that ParallelArrays are only compiled into nightly builds, but this apparently does not include the shell.
Depends on: 875342
Attached patch patchSplinter Review
This makes RELEASE_BUILD and NIGHTLY_BUILD work for the JS build as well, by copying most of the relevant logic from the main configure.in (with a bit of code removed since LIBXUL_SDK/printconfigsetting.py/platform.ini aren't relevant here).

EARLY_BETA_OR_EARLIER still doesn't work, because there's no equivalent build/defines.sh in js/src (and I'm not sure that I should refer to the existing one from this configure script?)

I need to re-test the patch in bug 875342 on beta to make sure it does what we want.
Attachment #756816 - Flags: review?
Assignee: general → gavin.sharp
Status: NEW → ASSIGNED
Comment on attachment 756816 [details] [diff] [review]
patch

I don't really know who should review this.
Attachment #756816 - Flags: review? → review?(sstangl)
Blocks: 875342
No longer depends on: 875342
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #1)
> I need to re-test the patch in bug 875342 on beta to make sure it does what
> we want.

Confirmed - this patch makes bug 875342's fix work as intended, on beta and trunk. As it is on trunk now, it's just entirely broken (parallelarrays are always disabled, typedarray.move is always enabled).
Attachment #756816 - Flags: review?(ted)
Attachment #756816 - Flags: review?(ted) → review+
Attachment #756816 - Flags: review?(sstangl)
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #1)
> EARLY_BETA_OR_EARLIER still doesn't work, because there's no equivalent
> build/defines.sh in js/src (and I'm not sure that I should refer to the
> existing one from this configure script?)

I filed bug 879836 for this.
http://hg.mozilla.org/integration/mozilla-inbound/rev/48afaae197ab
OS: Linux → All
Hardware: x86 → All
Target Milestone: --- → mozilla24
https://hg.mozilla.org/mozilla-central/rev/48afaae197ab
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 756816 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 853071
User impact if declined: developer confusion when using the new defines for JS stuff
Testing completed (on m-c, etc.): tested beta+nightly case manually, on m-c
Risk to taking this patch (and alternatives if risky): no risk
String or IDL/UUID changes made by this patch: none
Attachment #756816 - Flags: approval-mozilla-aurora?
Attachment #756816 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 885017
Depends on: 885034
No longer depends on: 885017
No longer depends on: 885034
You need to log in before you can comment on or make changes to this bug.