Marketplace missing on release build for Spain

RESOLVED INVALID

Status

--
blocker
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [POVB])

(Reporter)

Description

6 years ago
build ID:21030528231041

Marketplace app seems to be missing from the release build for Spain. This is alarming since Marketplace cannot be deleted from the phone.

Note that the marketplace app is available on the LatAm builds.
Flags: needinfo?(kward)

Updated

6 years ago
blocking-b2g: --- → tef+
Whiteboard: [POVB]

Comment 1

6 years ago
Confirmed on the same build. The icon displays but when operating on WI-FI get the error message " The URL is not valid and cannot be loaded"

The URL provided in the spec is: Spain: https://marketplace.firefox.com/minifest.webapp?carrier=telefonica&region=es
APP: http://marketplace.firefox.com/package.zip as documented in Bug 871196 .
This build also has the completely wrong grid layout but I will document that in a separate bug.
Flags: needinfo?(kward)
(Reporter)

Comment 2

6 years ago
Please note that in my case I don't see the app icon.
(In reply to kward@mozilla.com from comment #1)
> Confirmed on the same build. The icon displays but when operating on WI-FI
> get the error message " The URL is not valid and cannot be loaded"

That means you've configured the date incorrectly on your device. That happens when you load HTTPS content with an expired cert.
In combination with what I said in https://bugzilla.mozilla.org/show_bug.cgi?id=878342#c2, I think something got screwed up in the build process on the partner's side. There's nothing out of the ordinary I'm seeing in https://github.com/telefonicaid/firefoxos-gaia-spain/blob/master/homescreens.json. I can flash a custom build to check though.
Works for me on a 5/28 Spain customized partner build.

Are you absolutely sure you flashed the build correctly here?

qawanted and renom to have a second person run a flash here to double check my work.
blocking-b2g: tef+ → tef?
Keywords: qawanted
Another important question - what device was this bug filed against? The testing I did above was on Ikura.

Comment 7

5 years ago
It looks like there has no issue here. Close it for now and reopen when it's needed. Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
blocking-b2g: tef? → ---
Keywords: qawanted
(Reporter)

Comment 8

5 years ago
(In reply to Jason Smith [:jsmith] from comment #6)
> Another important question - what device was this bug filed against? The
> testing I did above was on Ikura.

This was tested on ikura which was flashed by Tony.

Comment 9

5 years ago
I can't reproduce this.  I installed a 5/30 TME build just now on the inari, and the marketplace app appears on the device.  Was able to launch the app, download, and install and open the Pulse app.
You need to log in before you can comment on or make changes to this bug.