Open Link in New Window not functional when pointing to a file that doesn't exist on user's machine

RESOLVED DUPLICATE of bug 136782

Status

RESOLVED DUPLICATE of bug 136782
18 years ago
14 years ago

People

(Reporter: rubydoo123, Assigned: sspitzer)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
using build from 2001062604 on win98
1. create a web page, save it
2. open mail, open new message and attach the web page, send it to yourself
3. open the message
4. mouse-over the link to the attachment displayed at the top of the window,
select 'Open Link in New Window' from the context menu.

Result: nothing happens

Expected: something, anything -- either open the attachment in a browser window
or generate an error dialog that staes it can't be found.

Comment 1

18 years ago
Beth are you still able to reproduce this.  I'm using the 6/27 build and am able
to do this.  Is it a particular link or all links that don't work for you?
(Reporter)

Comment 2

18 years ago
I am attaching an image to show what I was selecting in the note, hopefully that 
will help
(Reporter)

Comment 3

18 years ago
Created attachment 40363 [details]
image showing what was selected

Comment 4

18 years ago
Is that path valid for your computer? If not, then my guess is that we aren't
putting up a file not found dialog.
(Reporter)

Comment 5

18 years ago
correct, the line points to the original location of the file, I would expect 
to select that 'link' and have the associated attachment be displayed in a 
browser window, or put up the error dialog. But, I think the error dialog would 
confuse folks considering the attachment is there and is inline with the 
message.

Comment 6

17 years ago
There is a new regression in build 2001103003 which introduces identical behaviour
 to links in plain-text messages:
1. Send to yourself a message in plain text format with a link in its body
2. Open this message in MailNews
3. Right-click on the link and select "Open in New Window"

Nothing happens (although it worked in yesterday's builds - that is 2001102903)

Comment 7

17 years ago
Beth was reporting a different bug than the one that's happening in current
builds.  If there's not already a bug for the new one, I'll create one.

Comment 8

17 years ago
Created http://bugzilla.mozilla.org/show_bug.cgi?id=107779 for the new bug. 
Updating summary to better reflect bug.
Summary: Open Link in New Window not functional → Open Link in New Window not functional when pointing to a file that doesn't exist on user's machine
Should this bug be closed?

Comment 10

16 years ago
Still exists in Build 2003050714.

Hey, can someone add "4xp" to the Keywords list?  I don't have permission to do
so.

Comment 11

15 years ago
file://  URLs are not opened in email anyway, even if they do point to valid 
files; see bug 135830.

I don't think it's quite possible anymore to generate a message that will render 
exactly as seen in the screenshot attached to this bug.  If the Web page is 
actually an attachment, there is no link to it included in the body; if Send 
Page is used from the browser, the link will display as shown (viewed as 
plain-text) but the attached page won't render as HTML; if the message is 
dragged to the message body, it won't render inline nor show up in the 
attachments panel.  I'm picking a similar bug as the dupe for this...

See also bug 241572, bug 241573.

Re: comment 8 -- I have no idea what bug 107779 has to do with this bug, that 
must be a typo.

*** This bug has been marked as a duplicate of 136782 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.