Auto Update on Windows throught Proxy doesn't work

RESOLVED INVALID

Status

()

Toolkit
Application Update
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: sunweb, Unassigned)

Tracking

19 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512194440

Steps to reproduce:

We're using proxy with authentication. Firefox can work with it just fine, even remembering the passwords and logins.
But it won't update itself after the new version comes out.
Can it just update itself without confirmation like with direct connection ?

I didn't care for this stuff before i went administrating windows machines but now i do =(



Expected results:

Firefox must upgrade without me going to Help -> About Firefox
(Reporter)

Comment 1

5 years ago
Forgot to add. This feature is needed atleast for XP, don't care for Vista n 7 at the moment.

Updated

5 years ago
Component: Untriaged → Application Update
Product: Firefox → Toolkit

Comment 2

5 years ago
Are you able to update from old versions like FF19 or less?
Could you test with some old releases (see http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/) if you think there is a regression (just create a test profile, see https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles)
Flags: needinfo?(sunweb)
(Reporter)

Comment 3

5 years ago
I've tried actually. Its not a regression. Autoupdate simply doesn't work with proxy that requests authentication.
Component: Application Update → General
Flags: needinfo?(sunweb)
Product: Toolkit → Firefox
Version: 21 Branch → 19 Branch

Updated

5 years ago
Component: General → General
Product: Firefox → Core
Component: General → Application Update
Product: Core → Toolkit
Please type about:config in the url bar and click the button to display the content. Type app.update.log and double click it so its value is true. Restart Firefox and open Tools -> Error Console. Click the Clear button. Select Help -> Check for Updates. Please copy / pastes the entries that start with "AUS: " into into this bug report. If there are any errors please select / right click it and select copy those into the bug report as well. Thanks
(Reporter)

Comment 5

5 years ago
Ok, if that helps.

--------------------------------------------------------------------------------
1. Opened firefox -> enter the site so that proxy request established and access to internet was granted -> wait some time before autoupdate should kicked in -> watch the error console:
--------------------------------------------------------------------------------

AUS:SVC Creating UpdateService
AUS:SVC Checker: checkForUpdates, force: false
AUS:SVC getLocale - getting locale from file: resource://gre/update.locale, locale: ru
AUS:SVC Checker:getUpdateURL - update URL: https://aus3.mozilla.org/update/3/Firefox/21.0/20130511120803/WINNT_x86-msvc/ru/release/Windows_NT%205.1.3.0%20(x86)/default/default/update.xml
AUS:SVC gCanCheckForUpdates - able to check for updates
AUS:SVC Checker:checkForUpdates - sending request to: https://aus3.mozilla.org/update/3/Firefox/21.0/20130511120803/WINNT_x86-msvc/ru/release/Windows_NT%205.1.3.0%20(x86)/default/default/update.xml
UTM:SVC TimerManager:notify - notified @mozilla.org/updates/update-service;1
AUS:SVC Checker:onLoad - request completed downloading document
AUS:SVC Checker:onLoad - number of updates available: 0
UTM:SVC TimerManager:notify - notified @mozilla.org/addons/integration;1
Метка времени: 01.07.2013 10:51:50
Предупреждение: WARN addons.updates: Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property
Источник: resource://gre/modules/AddonUpdateChecker.jsm
Строка: 312
UTM:SVC TimerManager:notify - notified @mozilla.org/extensions/blocklist;1

Nothing happened.

--------------------------------------------------------------------------------
2. Went to force update and asked me proxy data again, entered the same data and obviously get update process just fine.
--------------------------------------------------------------------------------

AUS:SVC Creating UpdateService
AUS:SVC UpdateService:removeDownloadListener - no downloader!
AUS:SVC Checker: checkForUpdates, force: true
AUS:SVC Checker:getUpdateURL - update URL: https://aus3.mozilla.org/update/3/Firefox/21.0/20130511120803/WINNT_x86-msvc/ru/release/Windows_NT%205.1.3.0%20(x86)/default/default/update.xml?force=1
AUS:SVC Checker:checkForUpdates - sending request to: https://aus3.mozilla.org/update/3/Firefox/21.0/20130511120803/WINNT_x86-msvc/ru/release/Windows_NT%205.1.3.0%20(x86)/default/default/update.xml?force=1
AUS:SVC Checker:onLoad - request completed downloading document
AUS:SVC Checker:getUpdateURL - update URL: https://aus3.mozilla.org/update/3/Firefox/21.0/20130511120803/WINNT_x86-msvc/ru/release/Windows_NT%205.1.3.0%20(x86)/default/default/update.xml?force=1
AUS:SVC Checker:onLoad - number of updates available: 1
AUS:SVC gCanApplyUpdates - testing write access D:\Documents and Settings\username\Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\update.test
AUS:SVC gCanApplyUpdates - windowsVersion = 5.1
AUS:SVC gCanApplyUpdates - testing write access D:\Program Files\Mozilla Firefox\update.test
AUS:SVC gCanApplyUpdates - able to apply updates
AUS:SVC Creating Downloader
AUS:SVC UpdateService:_downloadUpdate
AUS:SVC readStringFromFile - file doesn't exist: D:\Documents and Settings\username\Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\updates\0\update.status
AUS:SVC readStatusFile - status: null, path: D:\Documents and Settings\username\Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\updates\0\update.status
AUS:SVC Downloader:downloadUpdate - downloading from http://download.mozilla.org/?product=firefox-22.0-partial-21.0&os=win&lang=ru&force=1 to D:\Documents and Settings\username\Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\updates\0\update.mar
AUS:SVC Downloader:onStartRequest - original URI spec: http://download.mozilla.org/?product=firefox-22.0-partial-21.0&os=win&lang=ru&force=1, final URI spec: http://download.cdn.mozilla.net/pub/mozilla.org/firefox/releases/22.0/update/win32/ru/firefox-21.0-22.0.partial.mar
AUS:SVC Downloader:onProgress - progress: 499562/12900264


ok it updated just fine any list after this is not needed since the problem happens earlier.
When the Firefox release drivers often first advertise an update they make it so background updates don't receive an update but manual updates do which is what comment #5 is showing. The background update url of
https://aus3.mozilla.org/update/3/Firefox/21.0/20130511120803/WINNT_x86-msvc/ru/release/Windows_NT%205.1.3.0%20%28x86%29/default/default/update.xml

currently opens the following:

<?xml version="1.0"?>
<updates>
</updates>

The foreground update url which has ?force=1 appended to it of
https://aus3.mozilla.org/update/3/Firefox/21.0/20130511120803/WINNT_x86-msvc/ru/release/Windows_NT%205.1.3.0%20%28x86%29/default/default/update.xml?force=1

currently shows
<?xml version="1.0"?>
<updates>
    <update type="minor" displayVersion="22.0" appVersion="22.0" platformVersion="22.0" buildID="20130618035212" detailsURL="https://www.mozilla.com/ru/firefox/22.0/releasenotes/" actions="silent">
        <patch type="complete" URL="http://download.mozilla.org/?product=firefox-22.0-complete&amp;os=win&amp;lang=ru&amp;force=1" hashFunction="SHA512" hashValue="833da249bcc30469734a329a815ededd4ecb25bf9c0a9b5b46918e859719795169407693e2fca93b6aad4fecad767cf08242f29a8369baa97bf369ed9efcdcb5" size="27337963"/>
        <patch type="partial" URL="http://download.mozilla.org/?product=firefox-22.0-partial-21.0&amp;os=win&amp;lang=ru&amp;force=1" hashFunction="SHA512" hashValue="ac86d3fd5848c6f6ed50e8c6e20444853a6ab85d68340686d1f78c10694b81c71de2df7c49e4df936e0bc0e41aff6229056de12c49e788e656e3243b303c3300" size="12900264"/>
    </update>
</updates>


This bug is invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
akeybl / lsblakk - is there a component for our release processes? I periodically have to triage these types of bugs and I think it would be a good thing for those that manage the release processes to be aware of them. Thanks
needinfo is for comment #7
Flags: needinfo?(lsblakk)
Flags: needinfo?(akeybl)
(Reporter)

Comment 9

5 years ago
Direct connection works fine, it checks update on the background, downloads it and install, no need for manual method. So this happens only with proxy. Again, how is it possible to autoupdate through proxy ? If there is no solution than this is still a bug.
(Reporter)

Comment 10

5 years ago
Maybe there is a way to fake update url ? If so, how is this possible ? Thanks.
(Reporter)

Comment 11

5 years ago
added ?force=1 at the end of app.update.url string, still nothing.
Rob, in reply to comment #7 if you need to flag something to the attention of release managers you can ni? on release-mgmt@mozilla.com -- we do not have a release process component and this doesn't come up often enough to warrant one yet.
Flags: needinfo?(lsblakk)
Flags: needinfo?(akeybl)
You need to log in before you can comment on or make changes to this bug.