Closed Bug 878419 Opened 8 years ago Closed 8 years ago

Syntax error in make_incremental_updates.py since bug 841094

Categories

(Release Engineering :: General, defect)

defect
Not set
blocker

Tracking

(firefox21 affected, firefox22 fixed, firefox23 fixed)

RESOLVED FIXED
Tracking Status
firefox21 --- affected
firefox22 --- fixed
firefox23 --- fixed

People

(Reporter: florian, Assigned: florian)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached patch PatchSplinter Review
Since we updated Instantbird to use Mozilla 21 (https://bugzilla.instantbird.org/show_bug.cgi?id=1956), nightly builds are broken because partial mar files fail to be generated, with this python error:

  File "/Users/buildbot/buildslave/macosx/build/mozilla/tools/update-packaging/make_incremental_updates.py", line 45
    m = re.match("((?:|.*/)distribution/extensions)/", filename):
                                                                ^
SyntaxError: invalid syntax
Attachment #756958 - Flags: review?(robert.bugzilla)
Keywords: regression
Comment on attachment 756958 [details] [diff] [review]
Patch

I suspect that Mike's python knowledge is greater than mine so pushing the review over to him.

nthomas, have we been seeing this internally as well and if we haven't do you know why?
Attachment #756958 - Flags: review?(robert.bugzilla) → review?(mh+mozilla)
Component: Application Update → Release Engineering
Product: Toolkit → mozilla.org
Version: 21 Branch → other
We don't exercise that logic at all for Firefox or Thunderbird.
Attachment #756958 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/4f4a4ae3629d
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 756958 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 841094
User impact if declined: No end-user impact, but it's an annoyance for users of make_incremental_updates.py and it would be great to no longer have to work around it in Mozilla 22.
Testing completed (on m-c, etc.): The patch here is currently applied after checking out the mozilla source code when building Instantbird nightlies.
Risk to taking this patch (and alternatives if risky): None; apparently it's not part of the Firefox and Thunderbird builds. It's even possible Instantbird is the only consumer as this bug hasn't been noticed before we updated to Mozilla 21.
String or IDL/UUID changes made by this patch: none.
Attachment #756958 - Flags: approval-mozilla-beta?
Attachment #756958 - Flags: approval-mozilla-aurora?
Comment on attachment 756958 [details] [diff] [review]
Patch

a=nptob
Attachment #756958 - Flags: approval-mozilla-beta?
Attachment #756958 - Flags: approval-mozilla-beta+
Attachment #756958 - Flags: approval-mozilla-aurora?
Attachment #756958 - Flags: approval-mozilla-aurora+
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.