Closed Bug 878422 Opened 7 years ago Closed 7 years ago

[Homescreen] Logo stays forever after the quick access bar crashed

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, b2g18 fixed, b2g18-v1.0.1 affected, b2g-v1.1hd fixed)

VERIFIED FIXED
blocking-b2g -
Tracking Status
b2g18 --- fixed
b2g18-v1.0.1 --- affected
b2g-v1.1hd --- fixed

People

(Reporter: wachen, Assigned: crdlc)

References

()

Details

(Whiteboard: [mozilla-triage])

Attachments

(8 files)

+++ This bug was initially created as a clone of Bug #877081 +++

Ikura(Open) v101 only - MOVISTAR&TME 20130601   <---This is easier to reproduce
Unagi v101
   PVT build 20130531
   Gecko revision="3b5f918b2c43ddebc0458457a2f127775b96cead"/>
   Gaia  revision="f13d8be2ff848bae3d72cd83a69abea5e3572311"/>
Unagi v1train
   PVT build 20130531  <---This is harder to reproduce


STR:
  1. Try to move in icons from homescreen to quick access bar till full.
  2. Try to move out icons from quick access bar to homescreen till 2~3 icons left
  3. Repeat this for few times

Expected result:
  Work as usually, you can move the icon around

Actual result:
  There would be 2 different actual results:
  1. The quick access bar crashed and whenever you move the icon, icon would be everywhere.
  OR
  2. The quick access bar is still alive, but the icon stays on the screen forever.
blocking-b2g: tef+ → tef?
Fixing the clone of the bug so that this goes through triage as usual.
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Hi Walter, I cannot reproduce this bug and Mila neither. I've seen an error in ensurePagesOverflow method and revoked URLs and re-validations. Maybe, sometimes, when this error is fired, the transitionend event is not invoked and the grid gets unstable. I've implemented a patch in order to solve this issue (only for v1-train in this moment)

https://github.com/crdlc/gaia/tree/bug-ensurePageOverflow
https://github.com/crdlc/gaia/commit/226d3099033a02be5b34e9d671ae717a4511cf5b

I would like you test it because you can reproduce the bug. Thanks a lot Walter
Flags: needinfo?(wachen)
Hi, crdlc,

Thanks for the quick patch. I think I can no longer reproduce this bug. I didn't see the 2 unexpected results again.

I think there is someone who can do this bug more easier than me. I will now needinfo from him. If he can no longer reproduce this, than this patch it the one.


Hi, whsu,

Can you please verify the patch again?

1. Prepare a phone with current pvt v1train build and
2. Commands
> git clone https://github.com/crdlc/gaia.git test_folder
> cd test_folder
> git branch test
> git checkout test
> git pull origin
> git pull origin bug-ensurePageOverflow
> make reset-gaia

And, you can then test the phone just like last week.
Flags: needinfo?(wachen) → needinfo?(whsu)
I cannot reproduce this issue.
triage: given Bug #877081 is fixed, the reproducible rate is lower and symptom is not as severe as before Bug #877081 is fixed (earlier it was multiple icons all screwing up the homescreen, currently if reproduced, only 1 icon is messed up). So, leo?
blocking-b2g: tef? → leo?
I found another bug that the icon would overlap and it might crash the arrangment of icons in homescreen. I don't think this is a good fix to go.
Hi, All,

A bad news. I still can reproduce this case and I found the performance the is worst than before. Does it cause by local build?
I found the three problems on the local build.
 1. All apps can be delete
 2. Icon still stays forever after the quick access bar
 3. The UI hang there without get any response.
Attaching the screenshot.


Thanks!
Flags: needinfo?(whsu)
Sorry for the typo.
"...I found the performance the is worst than before."
=> I found the performance is worse than before.
Attached video Home screen video
Hi, All,

> A bad news. I still can reproduce this case and I found the performance the is worst than before. Does it cause by local build?

Performance issues are not related to Homescreen app because there aren't changes in this part

> 1. All apps can be deleted
 
It was fixed and verified one week ago in bug 867045

https://github.com/mozilla-b2g/gaia/commit/cc2fd02fd461aa12c96e02229a78293365d65264

2. Icon still stays forever after the quick access bar

> I cannot reproduce it, sorry, and the most important thing is about screenshots are not useful for me because I need to watch a video reproducing the bug, before and after crashes. And logs during the same period /adb logcat | grep GeckoConsole/

> In any case, it is a bit strange :) because I cannot reproduce it, you can view all icons as removable (it was fixed), ... is your build ok? If the build is not ok, maybe the transitionend event is not fired and the drag&drop feature is getting unstable.

> summarizing... please provided me with logs and recorded video before and after bug appears

Thank you for the collaboration!
Please forget comment 11!

> A bad news. I still can reproduce this case and I found the performance the is worst than before. Does it cause by local build?

Performance issues are not related to Homescreen app because there aren't changes in this part

> 1. All apps can be deleted
 
It was fixed and verified one week ago in bug 867045

https://github.com/mozilla-b2g/gaia/commit/cc2fd02fd461aa12c96e02229a78293365d65264

> 2. Icon still stays forever after the quick access bar

I cannot reproduce it, sorry, and the most important thing is about screenshots are not useful for me because I need to watch a video reproducing the bug, before and after crashes. And logs during the same period /adb logcat | grep GeckoConsole/

In any case, it is a bit strange :) because I cannot reproduce it, you can view all icons as removable (it was fixed), ... is your build ok? If the build is not ok, maybe the transitionend event is not fired and the drag&drop feature is getting unstable.

Summarizing... please provided me with logs and recorded video before and after bug appears

Thank you for your work!
Hi, Cristian,

Attaching the adb log and please find the video via the following hyper link.
 - https://dc1.safesync.com/LMkyHWpf/Icon%20stays%20on%20homescreen.3gp?a=xWyRSLHcUOs
If you feel the definition of the video is not good, please download it to get clear version.
Thanks for your help!
E/GeckoConsole(  395): [JavaScript Warning: "Error in parsing value for 'transition'.  Declaration dropped." {file: "app://homescreen.gaiamobile.org/index.html#" line: 0}]

This problem is a bit strange. I am going to watch your video right now but I guess that the problem is in the build, not in Gaia or maybe in Gaia that is installed in your device. In order to reduce the are of action. What build are you using? Is it from Mozilla? Remember I am a worker from Telefonica and I don't have access to those builds. With current v1-train and gecko build on Unagi, I cannot reproduce the problem and the most important thing is what I can see in your video all icons as removable and it seems that something is not working well because it is not reproducible anymore after landing bug 867045. Could you test it on other build 2-3 weeks before?

Thanks
Hi, Cristian,

Thanks for youe help on this case.
I must say that this bug is hard to reproduce now, but it is still a potential issue.

I double test the case on unagi device. I still can reproduce this bug but it need spend 5~10 minutes.
If you feel a general user doesn't spend 5~10 minutes to move these icons of homescreen continuously, we may treat it as a minor issue and monitor this bug.

The following is my test build.
 * Mozilla-b2g18-unagi-eng/2013-05-31-23-02-04
  + Mercurial-Information
    - Gecko revision="36c6632443fb"
    - Gaia revision=""
  + Git-information
    - Gecko revision="fe01a25875349894a3e26d288e979dba22d4a7db"
    - Gaia revision="cac79d6e0f804af9a1203f45ca6b8eff13f1cf3e"

I flashed above build to unagi device, I did the following commands.
> git clone https://github.com/crdlc/gaia.git test_folder
> cd test_folder
> git branch test
> git checkout test
> git pull origin bug-ensurePageOverflow
> make reset-gaia
After that, I start my test.

So, do you think whether it makes sense?

One more question, I don't know why I need to test this bug on old build(2-3 weeks before).
We all knew that old build can easy reproduce this problem since old build is not yet had solve this problem.
Thanks! ^^
> I double test the case on unagi device. I still can reproduce this bug but it need spend 5~10 minutes.

I guess that if it happens after 5-10 minutes re-ordening icons, it wouldn't be a blocker. IMHO common users are not moving actually icons during that time. Although, I will try to reproduce it tomorrow with my Unagi. 

> One more question, I don't know why I need to test this bug on old build(2-3 weeks before)

My idea is to use an old build but with the current v1-train (my patch) so we can know if the problem is due to Gaia or Gecko. If you cannot reproduce this problem with current v1-train branch and gecko dated on 3 weeks ago we could say what the problem is due to Gecko, maybe some transitionend event lost. If you could reproduce the problem, the bus is on homescreen app, thought

Thanks
Hi, Cristian,

Thanks for your suggestions and help! ^^
Yes! The patch you provided fixed the part of access icon problems. It is not easy to reproduce the bug now. We can treat the legacy bug as minor issue but still need to fix it.

I did the the test you mentioned above to check whether it is Gecko's problem.
I used old V1-TRAIN build plus your patch to reproduce it.
The combination still can reproduce related bug.
Following is  my operations for your reference.
Step1: Flashing the following build to unagi.
       * Mozilla-b2g18-unagi-eng/20130510070207
Step2: Flashing your provided patch to unagi.

Step3: Start the test.

Test Result: Still can reproduce related bug but not easy.
Attaching the log.
OK, I am trying to reproduce the problem right now! Thanks for your help my friend!
Please, could you explain me the steps between 10-30 seconds? It seems that you are pressing a different icon than the one that is finally dragged, right?
I think we just tried to drag different icons from homescreen to quick access bar and vice versa. We choose icons randomly.
I mean, go to 13 seconds on the video, I can view how you are pressing on dialer app but finally the browser app is dragged, this is the problem! thought
Hi, Cristian,

^^! You found other interesting thing/bug. But it is not the bug that I want to mention.
During 10-30 seconds, I tried to drag icons from quick access bar to homescreen.
If you seek to 00:18 sec, 00:58 secs, and 01:35 sec, you will see the icon be zoomed in and cannot be placed in the right place.
Eureka! Watching and studying your recorded video I detected the problem. We have to wait for the re-arrange on grid and dock. I mean, if you look carefully how you reproduce the problem is trying to drag other icon from the dock while it is transitioning to the correct place. Please, I would like you test this patch before reviewing.

https://github.com/crdlc/gaia/tree/bug-878422-v2
https://github.com/crdlc/gaia/commit/2766651e555dc1ce2f6882e762c3a991b532793c
Hi, Cristian,

OOPS! I still can reproduce it. But I found that seems have something different than before.
Before the icon hangs on the homescreen, I saw the FFOS stop arrange/permute the homescreen icons. Please see the following video.
 * https://dc1.safesync.com/LMkyHWpf/VIDEO0089.3gp?a=iqmbOW60nsU
So, is it the root cause or just a side effect?

By the way, attaching the adb log for your reference.
While the bug happens, the error message always show the following message.
E/GeckoConsole( 2449): [JavaScript Warning: "Unknown property '-moz-align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]

Note: A tip to reproduce the case. Dragging the icon on the homescreen by using "∞" manner.

Thanks!
here you are

https://github.com/crdlc/gaia/tree/bug-878422-v2

I added the code to deal the url re-validations when there is overflow

Please keep me posted

Thanks
I cherry-pick in 2 commit you made and tested it.
I can't reproduce this bug.

However, it's beacause the performance degrade so much.
I can't even move the icon smoothly now.
I don't think this is a good patch :P
There is not worst performance, I don't know what do you mean, please flash your device again and make reset gaia with my branch, forget cherry picks. This patch is not related to performance issues. Last thing, I still see all icons as removable and it is not correct, please review what you are testing. I cannot reproduce it anymore with the path
If your commit can't be verified by cherry-pick, how do we know the commit would be right after two commits went into v1train? Also, just by testing your branch, the problem is still reproducible.
OK, two commits, squashing and asking some colleague from Telefonia QA as well because I am getting insane with this bug because I cannot reproduce any problem here with this patch

https://github.com/crdlc/gaia/tree/bug-878422-v2
https://github.com/crdlc/gaia/commit/ee0ba4f28ef6706cda85c45a1ab16ef888c03164

Thanks for your patience but it is very difficult for me to work in something what I cannot reproduce. I hope my colleague can reproduce it as well
Flags: needinfo?(rafael.marquez)
Sorry for the frustration. I don't mean to do so, it is all because that I usually played phone like a bad user. 5 of us in Taipei tried this, and only less half of us are able to reproduce it. I will be providing more information once I figure out a reliable way to reproduce it. Finally, thanks for your helping on patches, we really appreciate it.
Good news my friends!! I hope so... Thanks to Walter, William and Rafa I could reproduce the problem. Right now, after applying my last approach, I cannot reproduce it anymore. Well, maybe you can jejeje , step by step, thanks for your patience.

https://github.com/crdlc/gaia/tree/bug-878422-v2
https://github.com/crdlc/gaia/commit/550efb31ec5ab14392506259266e43a11ca77c7f

Other thing very important about performance:

Gecko-45b1437 performance OK (7 days ago)
Gecko-3b5f918 the performance is worse (06-05-13)

Keep me posted here!

Thanks
Flags: needinfo?(rafael.marquez)
(In reply to Cristian Rodriguez de la Cruz (:crdlc) from comment #34)
> Other thing very important about performance:
> 
> Gecko-45b1437 performance OK (7 days ago)
> Gecko-3b5f918 the performance is worse (06-05-13)
> 

[leo triage]
Bug 880390 addresses the performance issue and was r+'d this less than an hour ago. It would make sense to retest this Homescreen logo issue after that patch lands. This won't be a blocker if the performance issue is addressed.
Keywords: verifyme
Whiteboard: [mozilla-triage]
Keywords: verifymeqawanted
Attachment #761315 - Flags: review?(jmcf)
Leo will do some tests
Flags: needinfo?(jaeohkim83)
also seeing if walter can retest.
Flags: needinfo?(wachen)
On Unagi v1.1.0 Build ID: 20130612070210
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/b4f8f0a288ca
Gaia: 547db47241459b5944ba40bacc94b15977d8a02e

After filling the bar full and removing one app at a time I encountered the app not going to either the bar or on the homescreen.
I will do the test later :P
David, I think it could be reproduced in v1.1.0 and v1.0.1. Any phone on these branches can reproduce the bug.

Also, if you click home button when the one icon stuck, it might crash the bar. in that case, all icons moving around might be stuck.
Flags: needinfo?(jaeohkim83)
Hi Walter,

   You have to check the patch added in Comment 36

thanks
Hi, Cristian,

Thanks for your prompt help.
I still can reproduce this bug after I applied the patch of comment 36.
The following is the adb log. FYI.
william@tpemozilla:~/Workspace_B2G/Crdlc_repo$ adb logcat | grep GeckoConsole
E/GeckoConsole(  404): Security Error: Content at app://homescreen.gaiamobile.org/index.html#root may not load data from blob:261c5bee-6701-4b2b-9d1e-fc0f70beaa12.
E/GeckoConsole(  404): [JavaScript Warning: "Error in parsing value for 'transition'.  Declaration dropped." {file: "app://homescreen.gaiamobile.org/index.html#" line: 0}]
E/GeckoConsole(  404): [JavaScript Warning: "Error in parsing value for 'transition'.  Declaration dropped." {file: "app://homescreen.gaiamobile.org/index.html#" line: 0}]
E/GeckoConsole(  404): [JavaScript Warning: "Error in parsing value for 'transition'.  Declaration dropped." {file: "app://homescreen.gaiamobile.org/index.html#" line: 0}]
E/GeckoConsole(  404): [JavaScript Warning: "Error in parsing value for 'transition'.  Declaration dropped." {file: "app://homescreen.gaiamobile.org/index.html#" line: 0}]
E/GeckoConsole(  108): [JavaScript Warning: "Invalid URI. Load of media resource  failed." {file: "app://system.gaiamobile.org/index.html" line: 0}]


These ERROR message seems look like same as before.
I recommend to add more log to trace it on local build if you don't mind.
What do you think?
Have a nice day! ^^
This trace is not important here and it is not related, don't worry, it is related to scale when there is not icons on the dock. I cannot reproduce it anymore applying the patch so IMHO I can't continue working on it, please, Rafa, could you check it again and provide me with new steps?
Flags: needinfo?(rafael.marquez)
Hi, Cristian,

WOW~ My brother! I can easy reproduce it now. Are you still interested in this bug?
Please see the following video first if you are available then I will explain my finding below.
>> Video 1: https://dc1.safesync.com/LMlQwjkt/HomeScreen/VIDEO0095.3gp?a=jbGnEawba4Y
>> Video 2: https://dc1.safesync.com/LMlQwjkt/HomeScreen/VIDEO0096.3gp?a=Buve4mrhg8g

In a general case, while you move a icon from quick acess bar(dock) to homescreen, the icon name should be hidden. But I found a interesting thing. When the bug will happen, you move a icon from quick access bar to homescreen. The icon name still here. So, it might have something wrong regarding judgement of icon location.

In order to prevent human error, I also provide the test build and build installation steps for your reference.
Step 1: Flashing the following PVT build into unagi device.
      * Mozilla-b2g18-unagi-eng/2013-05-27-07-02-08
Step 2: Download the customization gaia and reset the device
      $ git clone https://github.com/crdlc/gaia.git Crdlc_repo
      $ git branch 878422_patch
      $ git checkout 878422_patch 
      $ git pull origin bug-878422-v2
      $ make reset-gaia
Step 3. Start the test.
      >> Dragging a icon of quick access bar(dock) and move it between quick access bar(dock) and homescreen.
      >> While the icon is under the quick access bar(dock) but the icon name still here, please move it to the home screen.

By the way, if you still cannot reproduce it, I will ask for my colleague's assistance and check my test environment.
You also can mark as "WORKFORME" then reopen it while it happens again.
Thanks!
I gonna try to reproduce it again.
Hi my friend,

I cannot reproduce it :(

 https://dc1.safesync.com/LMlQwjkt/HomeScreen/VIDEO0095.3gp?a=jbGnEawba4Y

The steps are:

git clone https://github.com/crdlc/gaia.git crdlc_repo
git fetch
git checkout bug-878422-v2
git pull origin bug-878422-v2
make reset-gaia
Finally I can reproduce the second video but jumping 20 times between dock and grid, taking a look deeper
Please pull again the branch, I have just modified the patch to ensure when there is not transitionend event between fast movements
Flags: needinfo?(rafael.marquez)
Keywords: qawanted
I can still reproduce it :P
Flags: needinfo?(wachen)
Ok, I can't reproduce it now :P
Hi, Cristian,

WOW~"You did it!" I also cannot reproduce this case now.
As I discussed test result with Walter, Walter mentioned the result of comment 50 that applied the  patch of comment 36. So, Walter still can reproduce it. After Walter and I applied the latest patch, we cannot reproduce this case now.
Now, the icon will be placed in the first icon of next page instead of hanging there.
I don't have further concern regarding this bug. You can make as "RESOLVED".
But, please make sure that the related patch is also merged, e.g. all apps can be removed, etc...
Really~Really appreciate your help! Have a nice weekend! ^^
Awesome news at the end! Thanks for your patient my friends. Right now is the turn of the reviewer. Cheers
Attachment #762562 - Flags: review?(jmcf)
Attachment #761315 - Flags: review?(jmcf)
Attachment #762562 - Flags: review?(jmcf) → review+
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Note - patches need a leo+ to land on v1-train to land at this point. Too late I guess now though, since the patch already landed on v1-train.
1.1hd: bb35fd19ee31f5ed2bb342a9ad02c4577a1e6f1f
Flags: in-moztrap?
Verified fixed in 2013/06/16 V1train pvt build.
Gaia:     f2d6ed54a236e6e3b94f0abad9f0dacb8a1cc7b3
  B-D     2013-06-15 07:33:44
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/15d9885034a0
BuildID   20130616070209
Version   18.0
Status: RESOLVED → VERIFIED
Flags: in-moztrap?
Please reference on this video from Willian Hsu for making test cases.
>> Video 1: https://dc1.safesync.com/LMlQwjkt/HomeScreen/VIDEO0095.3gp?a=jbGnEawba4Y
>> Video 2: https://dc1.safesync.com/LMlQwjkt/HomeScreen/VIDEO0096.3gp?a=Buve4mrhg8g
Flags: in-moztrap?
Sorry Jason per comment 56, I know how to work it :) but after landing I realized that the bug wasn't leo. At that moment, I knew that I was wrong but I though if somebody want I could revert the patch although it fails as well without the patch. Do you want that I remove it from v1-train?

Sorry and thanks for your comment
Flags: needinfo?(jsmith)
At this point, it's probably fine to leave the patch in rather than back the patch out unless we see severe regressions.
Flags: needinfo?(jsmith)
This is found in v1.0.1 in Buri shipped version (0611 Partner build) from Steven Yang.

CC Steven Yang now.

Should we still put this patch into v101?
blocking-b2g: leo? → -
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.