Black text on popup dialogs is impossible to read in sunlight.

RESOLVED INVALID

Status

()

Firefox for Android
Theme and Visual Design
RESOLVED INVALID
4 years ago
a year ago

People

(Reporter: ties, Unassigned)

Tracking

24 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 757010 [details]
Screenshot of terrible dialog contrast.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.94 Safari/537.36

Steps to reproduce:

Surf to a website that asked for my location.


Actual results:

A dialog popped up asking whether I'd like to allow the website to know my location.
There were two buttons, but since they were very dark and had black text on them, I could not see what button to press in daylight conditions.


Expected results:

The buttons should have been lighter so that the black text can be read, or the text should have been white.
(Reporter)

Updated

4 years ago
OS: Windows 7 → Android
Hardware: x86_64 → ARM
This will depend on the device, Android version. Which device is this? The front-end team has also done improvements to this area on Nightly and Aurora. If you try out Nightly (http://nightly.mozilla.org) for Android or Aurora (mobile) (http://aurora.mozilla.org) for Android, do you see the same thing?
(Reporter)

Comment 2

4 years ago
This is on a Sony Xperia Active running the latest update (ICS).
Will give that a try and get back to you.
(Reporter)

Comment 3

4 years ago
I can confirm that this problem has been resolved in Aurora. Thank you for your time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.