Closed Bug 878476 Opened 9 years ago Closed 9 years ago

[calendar] week view: two month names in header despite all days of week belong to one month

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.3 C3/1.4 S3(31jan)

People

(Reporter: aryx, Assigned: mmedeiros)

References

Details

(Whiteboard: [p=3])

Attachments

(1 file)

Gaia 1.1.0.0-prerelease 20130601070210 on Unagi

The week view header of the calendar sometimes shows two month names despite all days of week belong to one month.

Steps to reproduce:
1. Launch calendar in month view (or at least not view week view at the end of June 2013, see bug 806756).
2. Go to June 2013.
3. Select the 26th.
4. Tap on 'Week' view.
5. Swipe left to get the view for June 28th to 30th 2013.

Actual result:
Header shows "June July 2013".

Expected result:
Header shows "June 2013".

If you swipe again left for the view from 1st to 4th of July 2013, the header correctly shows "July 2013".

I'm in UTC+0200.
Confirmed. Probably just need to fix our double month calculation here.
seems trivial to fix and I'm doing some other stuff which involves the time header as well, so I think I should just go ahead and fix this as well.
Assignee: nobody → mmedeiros
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
Whiteboard: [p=3]
Depends on: 803238
Attachment #8368849 - Flags: review?(gaye) → review+
https://github.com/mozilla-b2g/gaia/commit/67f11d9b60750270f0bea834832e8108e95204e8 thanks Miller!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Hi Miller,
Is it possible to add a '-' between the two months of the same year. For example, Jun - July 2013. And if the year is different, then show something like Dec 2013 - Jan 2014?
Flags: needinfo?(mmedeiros)
Hi Harly; Since we are adding the notification icon on v1.4 I don't think we can fit "Dec 2013 - Jan 2014" .. since it's an edge case I think we could probably use the same format as other months ("Dec - Jan 2014"); everyone knows that December is the last month of the year, so it should be clear enough that "2014" refers only to "Jan". I also think we will need to update the day view header to display as "Feb 12, Wed" instead of "Feb 12, Wednesday" (because of notifications as well).

If you think we should move forward with the changes, please create a new issue for it. Thanks!
Flags: needinfo?(mmedeiros) → needinfo?(hhsu)
Hi Miller,
Do you happen to know how many characters can we have after adding the notification icon?
It looks fine to have "Feb 12, Wed" instead of "Feb 12, Wednesday", and "Dec - Jan 2014" instead of "Dec 2013 - Jan 2014".
Flags: needinfo?(hhsu)
Comment on attachment 8368849 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/15881

This patch is only in master branch(v1.4). Can anyone help uplift this to v1.3?
Attachment #8368849 - Flags: approval-gaia-v1.3?
Comment on attachment 8368849 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/15881

We're only accepting blockers on the 1.3 branch at this time, so a-.
Attachment #8368849 - Flags: approval-gaia-v1.3? → approval-gaia-v1.3-
You need to log in before you can comment on or make changes to this bug.