Click on link is un responsive, after zoom in or zoom out, link is responsive

UNCONFIRMED
Unassigned

Status

()

Firefox for Android
General
UNCONFIRMED
5 years ago
a year ago

People

(Reporter: Daniel, Unassigned)

Tracking

21 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.24 (KHTML, like Gecko) Chrome/11.0.696.34 Safari/534.24

Steps to reproduce:

When Clicking on a link (Using a USB mouse) it will not register a link click. However after zoom in or out, the link is cclick able once again.

Pages that it happens on most are complex pages such as amazon.com, Certian links will turn orage when i hover over with the mouse and will work properly, some will not turn orange and donothing upon click.

Other Note: scrolling up or down will often resolve the issue temporarly. I think it has to do with mouse wheel scrolling and firefox getting comfused where the links are. it is easly reproducible on the amazon recent orders screen. Link: https://www.amazon.com/gp/css/order-history/ref=ya_orders_css_t1

I can send a video oYouTube if necessary to demonstrate the bug. 


Actual results:

No rresponse

Pages that it happens on most are complex pages such as amazon.com, Certian links will turn orage when i hover over with the mouse and will work properly, some will not turn orange and donothing upon click.

Other Note: scrolling up or down will often resolve the issue temporarly. I think it has to do with mouse wheel scrolling and firefox getting comfused where the links are. it is easly reproducible on the amazon recent orders screen. Link: https://www.amazon.com/gp/css/order-history/ref=ya_orders_css_t1

I can send a video oYouTube if necessary to demonstrate the bug. 


Expected results:

Should have clicked the link like normal.
(Reporter)

Updated

5 years ago
OS: Linux → Android
Hardware: x86_64 → ARM
Are you saying you encounter this using a USB mouse?

Device? Build? Android OS version?
Also do you see this with Nightly for Android (http://nightly.mozilla.org) ?

Updated

5 years ago
Flags: needinfo?(danrenfroe2016)
(Reporter)

Comment 3

5 years ago
Droid Bionic, Android 4.1.2, Version 21.

I have not tried the nightly.

Same bug when using HDMI with mouse connected and used with Motorola Webtop 100. 

Note: I can not reproduce it using the touch screen, it is definitely related to using the scroll wheel on the USB mouse, after scrolling to bottom of page, cant click on certain links, some are active, others are not, as soon as zoom in or out the links will work again. 

is anyone else able to reproduce?
Flags: needinfo?(danrenfroe2016)
Not sure who has this setup who can try this out.
The Webtop environment is not supported by Mozilla, try Motorola. It is also not Firefox for Android.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

5 years ago
Kevin,

The current Webtop 3.0 is just android Jelly Bean run at 720P tablet interface, Motorola webtop is no longer in service. It is the standard firefox in android. However, I will confirm if it happens or not when NOT in webtop mode. I will try tonight "on phone screen" with my bluetooth mouse to see if the bug is present. Thanks.
I was not aware that Motorola had continued development of Webtop. Specs on the ICS device can be found at http://www.motorola.com/us/consumers/Motorola-Lapdock-500-PRO/77653,en_US,pd.html
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 8

5 years ago
Ok. Its Jelly Bean. Webtop in Jellybean basically just changes the display to tablet mode 720p, does the same when i connect the phone via hdmi to a tv. I.E. they ditched the "computer like webtop with the full firefox.". 

Here is the Video of the bug. http://youtu.be/lkHyP62Fs4M

Note: I can not get it to do it in phone mode with a bluetooth mouse.

I think it does it after the left sidebar is opened for additional tabs and then closed again. At first i though it had to do with scrolling with the mouse scroll wheel. Thanks.

If someone has a tablet with firefox and jellybean, see if they can reproduce the issue. I think best place to see bug is to open and close tab drawer on the side and then try various links. Frustrating part is that i can not get it do do it consistently...
It kind of looks like Android is putting the focus on some other UI element and then not delivering clicks to the content any more. I would expect clicking on the content to move the focus back but maybe it only does that on double-click? Not really sure. I don't have a setup to reproduce this. CC'ing sriram in case this looks familiar to him, being the UI focus expert and all :)
You need to log in before you can comment on or make changes to this bug.