RFE: Ability to have multiple search msg windows open

RESOLVED DUPLICATE of bug 55557

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED DUPLICATE of bug 55557
17 years ago
10 years ago

People

(Reporter: Frank Tang, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This is another feature I love to have. Currently, we only allow one message 
searching window. I hope we can have more than one at the same time.
this might be fixed on the trunk already.

the search window used to be a dialog, but last night I landed a patch from
blake to make it a window.  I'll test and find out.
Severity: normal → enhancement
Summary: FER: miltiple message searching window → RFE: multiple message searching window

Comment 2

17 years ago
Seth, I think there's a bug reported that if you open a second window - all the
popupmenus in the new search dialog are blank.

Anyway, if this bug is valid - it should go to the Search/Filters component.
well, it didn't work.  

doing "Search | Search Mail News Messages" again while search is open and your
search window gets horked.  

in 4.x, doing search again just brings the search window to the front.

frank's RFE would be to make it open multiple message searching windows

when I investigate fixing the "horked" issue, I can see if it is possible to
open another window.
Severity: enhancement → normal
Keywords: 4xp
Summary: RFE: multiple message searching window → "Search | Search Mail News Messages" again while search is open and your existing search window gets horked (should it open multiple message searching windows?)
> I think there's a bug reported that if you open a second window - all the
> popupmenus in the new search dialog are blank.

I'm unable to open the second window, but that's what is happening to my first 
window.

if that is an existing bug, we can turn this back into frank's original RFE (and 
make this depend on that bug.)

Comment 5

17 years ago
I'm also unable to open a second window, however when you try - note how all
criteria popupmenus gets blank (which is what the bug I'm talking about is all
about.)

Updated

17 years ago
QA Contact: esther → laurel

Comment 6

17 years ago
The bug about the first window surfacing and having blank/useless fields is bug
44799 and affects both search and filter(rules) UIs.

Comment 7

17 years ago
Turning this bug into ftang's original request, like Seth mentioned. Will make
it dependent on 44799.
Taking 4xp keyword away, since 4.x doesn't allow multiple search windows (I
think that keyword was placed here for the 44799 condition).
Severity: normal → enhancement
Depends on: 44799
Keywords: 4xp
Hardware: PC → All
Summary: "Search | Search Mail News Messages" again while search is open and your existing search window gets horked (should it open multiple message searching windows?) → RFE: Ability to have multiple search msg windows open

Comment 8

16 years ago
Now (in 1.3b), when you try to open a new Search messages window, the existing
window just comes to the front (without any problem, AFAICS).

Implementing this RFE would also solve bug 173477.
OS: Windows NT → All
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Updated

11 years ago
Blocks: 173477

Comment 9

11 years ago
dupe of bug 55557?

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 55557
You need to log in before you can comment on or make changes to this bug.