crash in mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor with abort message: "constructor for actor failed"

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
critical
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({crash})

Trunk
x86
Windows Vista
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 757103 [details]
windbg stacktrace

had opened a couple links related to oprah havard speech.
but, I've also had a string of EMPTY crash reports in the last couple days:
- bp-55ac3a7e-ebb4-42c3-99ca-665e72130601	6/1/2013	1:47 PM
- bp-42af1291-87b0-40e0-86f3-84a0d2130525	5/25/2013	5:18 PM


This bug was filed from the Socorro interface and is 
report bp-42dc0702-6400-4513-a5e0-63c4c2130602 .
============================================================= 

(1524.1754): Break instruction exception - code 80000003 (!!! second chance !!!)
eax=00000000 ebx=601ebf04 ecx=662d3896 edx=00000003 esi=66281ec6 edi=662d379c
eip=73a9198b esp=0025ea64 ebp=0025ea6c iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00200202
mozalloc!mozalloc_abort+0x2e:
73a9198b 6a03            push    3
0:000> ~* kp;!analyze -f;lm

.  0  Id: 1524.1754 Suspend: 1 Teb: 7ffdf000 Unfrozen
ChildEBP RetAddr  
0025ea6c 5fd082d0 mozalloc!mozalloc_abort(char * msg = 0x0025eaa0 "###!!! ABORT: constructor for actor failed: file e:/builds/moz2_slave/m-cen-w32-ntly-000000000000000/build/obj-firefox/ipc/ipdl/PPluginInstanceChild.cpp, line 820")+0x2e [e:\builds\moz2_slave\m-cen-w32-ntly-000000000000000\build\memory\mozalloc\mozalloc_abort.cpp @ 30]
0025ee98 5f4f19db xul!NS_DebugBreak(unsigned int aSeverity = 3, char * aStr = 0x5fe6b1d0 "constructor for actor failed", char * aExpr = 0x00000000 "", char * aFile = 0x5fe6dca0 "e:/builds/moz2_slave/m-cen-w32-ntly-000000000000000/build/obj-firefox/ipc/ipdl/PPluginInstanceChild.cpp", int aLine = 0n820)+0x1c0 [e:\builds\moz2_slave\m-cen-w32-ntly-000000000000000\build\xpcom\base\nsdebugimpl.cpp @ 409]
0025eefc 5fa6ac9f xul!mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor(class mozilla::plugins::PStreamNotifyChild * actor = 0x01b0ea30, class nsCString * url = 0x0025ef40, class nsCString * target = 0x0025ef28, bool * post = 0x0025ef52, class nsCString * buffer = 0x0025ef34, bool * file = 0x0025ef53, short * result = 0x0025ef4c)+0x175 [e:\builds\moz2_slave\m-cen-w32-ntly-000000000000000\build\obj-firefox\ipc\ipdl\pplugininstancechild.cpp @ 821]
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Windows\system32\Macromed\Flash\NPSWF32_11_7_700_202.dll - 
0025ef54 56abf5c2 xul!mozilla::plugins::child::_geturlnotify(struct _NPP * aNPP = 0x02615970, char * aRelativeURL = 0x0263c788 "http://s.youtube.com/s?volume=100&nsivbblmean=369249.438&hosted=1&nsiabblmin=47343.000&vtmp=1&playerw=640&nsiabblmax=66998.000&playerh=360&ptk=youtube_none&nsivbblmin=257591.000&scoville=1&nsiabblmean=54190.750&mos=0&h=360&plid=AATeKjMfkW1gV5yp&nsivbblc=16&cver=as3&ns=yt&abd=1&rt=49.896&fmt=134&vq=auto&et=10.972&st=0&el=embedded&hl=en_US&nsiabblc=16&sendtmp=1&fs=0&fexp=919112,916623,900352,924605,928201,901208,929123,929915,929906,925714,929919,929119,931202,932802,928017,912512,912518,911416,906906,904476,930807,919373,906836,933701,926403,912711,929606,910075&bc=2384964&ps=chromeless&afmt=140&len=1739&vh=360&splay=1&decoding=software&nsidf=295&eurl=http%3A%2F%2Fplayer.ooyala.com%2Fstatic%2Fcacheable%2Fc3d327ff6e3f06fdde769275ca5ef76f%2Fplayer_v2.swf%3Fversion%3D2%26embedType%3Dnuplayer%26embedStyle&rendering=software&md=1&vw=640&tsphab=1&docid=GMWFieBGR7c&tspne=0&bd=1199813&tspfdt=3441&bt=10.906&w=640&next_id=GMWFieBGR7c&hasstoryboard=1&audiofactor=1.7516606505770222&idpj=0&ldpj=0&tpmt=9&cfps=0.4230357042134356&hcbd=1152182&screenw=1280&hcbt=7.343999999999999&cpn=s_fJZOTSkcuFpqa5&screenh=800&uga=m54&nsivbblmax=534453.000&vid=idUjLGWwf45QmJo4Zq0s9D3QtmZSga-oC", char * aTarget = 0x00000000 "", void * aNotifyData = 0x0000016e)+0xab [e:\builds\moz2_slave\m-cen-w32-ntly-000000000000000\build\dom\plugins\ipc\pluginmodulechild.cpp @ 1061]
WARNING: Stack unwind information not available. Following frames may be wrong.
0025f268 56ad2f1f NPSWF32_11_7_700_202!native_ShockwaveFlash_TCallLabel+0x140f94
0025f278 56ad0e43 NPSWF32_11_7_700_202!native_ShockwaveFlash_TCallLabel+0x1548f1
0025f290 56ad7e37 NPSWF32_11_7_700_202!native_ShockwaveFlash_TCallLabel+0x152815
0025f2b4 56adf137 NPSWF32_11_7_700_202!native_ShockwaveFlash_TCallLabel+0x159809
0025f2b8 56ad427c NPSWF32_11_7_700_202!native_ShockwaveFlash_TCallLabel+0x160b09
0025f2ec 56ad4fd9 NPSWF32_11_7_700_202!native_ShockwaveFlash_TCallLabel+0x155c4e
0025f324 56ad3469 NPSWF32_11_7_700_202!native_ShockwaveFlash_TCallLabel+0x1569ab
0025f334 56ad5f3c NPSWF32_11_7_700_202!native_ShockwaveFlash_TCallLabel+0x154e3b
0025f36c 56973e67 NPSWF32_11_7_700_202!native_ShockwaveFlash_TCallLabel+0x15790e
0025f388 7783657a NPSWF32_11_7_700_202!NP_Acrobat_GetEntryPoints+0x384
0025f39c 01e87c40 ntdll!RtlFreeHeap+0x101
0025f3b0 56f2b161 0x1e87c40
0025f3cc 7783657a NPSWF32_11_7_700_202!IAEModule_IAEKernel_UnloadModule+0x2587f1
0025f3e0 0025f494 ntdll!RtlFreeHeap+0x101
0025f400 56f2b180 0x25f494
00000000 00000000 NPSWF32_11_7_700_202!IAEModule_IAEKernel_UnloadModule+0x258810
(Reporter)

Comment 1

5 years ago
some of the last links opened are below. I'm thinking the first link is what firefox tanked on.

http://www.washingtonpost.com/national/oprahs-harvard-commencement-speech/2013/05/31/d8a1e070-c9ef-11e2-9f1a-1a7cdee20287_video.html

http://www.parade.com/18717/viannguyen/5-best-quotes-from-oprah-winfreys-inspiring-harvard-university-commencement-speech/

http://www.parade.com/18717/viannguyen/5-best-quotes-from-oprah-winfreys-inspiring-harvard-university-commencement-speech/

https://www.facebook.com/search/results.php?init=quick&q=parade%20magazine%20oprah%20harvard%20quotes&tas=0.47926725060662956&form=FBKBFR&type=web

http://www.wwmt.com/shared/entertainment/features/entertainment/stories/wwmt_memorial-day-events-426.shtml?wap=0

Comment 2

5 years ago
It might be bug 868919.

The three other empty dump crashes are unrelated.
Crash Signature: [@ EMPTY: no crashing thread identified; corrupt dump] → [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor(mozilla::plugins::PStreamNotifyChild*, nsCString const&, nsCString const&, bool const&, nsCString const&, bool const&, short*)]
Component: Untriaged → Plug-ins
Product: Firefox → Core
Summary: crash in EMPTY: → crash in mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor with abort message: "constructor for actor failed"
(Reporter)

Comment 3

5 years ago
(In reply to Scoobidiver from comment #2)
> It might be bug 868919.

FWIW, the video http://www.washingtonpost.com/national/oprahs-harvard-commencement-speech/2013/05/31/d8a1e070-c9ef-11e2-9f1a-1a7cdee20287_video.html was playing in a tab that had been opened in the background, and was never in the foreground (I never switched to it).  I've played it once since restarting firefox, and no crash. 


> The three other empty dump crashes are unrelated.

the last of the three goes with *this* crash.
I assume this isn't reproducible?
Priority: -- → P3
(Reporter)

Comment 5

5 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #4)
> I assume this isn't reproducible?

not so far. And I suspect unlikely to occur in the future. So what you've got from me in this bug report might be all you'll get.

that said, getting EMPTY crash reports is not unusual for me.  But I also rarely play videos.

Updated

2 years ago
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor(mozilla::plugins::PStreamNotifyChild*, nsCString const&, nsCString const&, bool const&, nsCString const&, bool const&, short*)] → [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor(mozilla::plugins::PStreamNotifyChild*, nsCString const&, nsCString const&, bool const&, nsCString const&, bool const&, short…
(Reporter)

Comment 6

2 years ago
I ran that vista system until Jan 2015, and I don't recall such crashes in at least 6 months prior (i.e. during 2014)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.