GIF favicon animation out of sync with image in ImageDocument

NEW
Unassigned

Status

()

Core
ImageLib
P1
normal
5 years ago
3 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 757166 [details]
DEAL WITH IT GIF

This GIF stops animating in the page when the "deal with it" caption is shown.

But, oddly, if you switch to another tab you'll immediately see the favicon start animating again, but upon switching back the image is still frozen at the "deal with it" frame.

I can not deal with it. :(
This feels exactly like bug 876332 which landed recently (and I can't reproduce this bug in an up-to-date Nightly); please reopen if that's not so!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 876332
(Reporter)

Comment 2

5 years ago
Yeah, it's mostly-fixed in a current Nightly. But I still see two weird things:

1) The favicon animation and the in-content image can be animating massively out-of-sync. Shouldn't all instances of an animation be in sync?

2) Upon switching to (or away! wat) from the tab with the image loaded, the favicon animation resets to the beginning.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
True! But both of those are nothing new, it seems. Do you want to morph this bug into one of them and file another for the other behaviour?
Flags: needinfo?(dolske)
(Reporter)

Comment 4

5 years ago
I guess that depends on "new", I thought in the past all animations (for a particular file) were synchronized, since there was a single timer driving the animation.

Let's call this bug about #1 from comment 2, and I'll clone this for #2.
Flags: needinfo?(dolske)
Summary: GIF stops animating → GIF favicon animation out of sync with image in ImageDocument
(Reporter)

Updated

5 years ago
Status: REOPENED → NEW
(Reporter)

Updated

5 years ago
Blocks: 880128
(Reporter)

Updated

5 years ago
Blocks: 880131
You need to log in before you can comment on or make changes to this bug.