none of the links on harrods.com work.

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Dave, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.1+) Gecko/20010626
BuildID:    2001062609

Clicking on the links or choosing the options from the drop down at this site
are supposed to replace the image at the center of the window. When I try this
under mozilla, the page appears to reload but the image doesn't change.

I'm putting this under DOM but it may well be wrong and belong under evangelist,
forms, tables, etc... I really can't figure out exactly how the html on the page
works and the links (the top row which includes "food hall" for example) seem to
work differently from the drop down.

The links look like they call some kind of asp page, like so:

<td width="410" colspan="2" height="7" valign="middle" align="left">
&nbsp;&nbsp;&nbsp;&nbsp; <a
href="category.asp?catalog%5Fname=Directorate&dir_category=Food+Halls&category_name=Food+Halls&category_oid=2&page=1"
class="HarrodsDirectoratesMenu" onmouseover="statusBar('FOOD HALLS');return
true" onmouseout="statusBar('');return true">FOOD HALLS</a>&nbsp;<a
class='HarrodsBullet'>&#8226;</a>&nbsp;<a
href="category.asp?catalog%5Fname=Directorate&dir_category=Toy+Kingdom&category_name=Toy+Kingdom&category_oid=1&page=1"
 [...and so on...] 
</td>

while the select box calls a JS function onchange which looks like so:

// Drop Down Combo Box Hyperlink Script, PL@Liquorice 5 March 2001 =========
function serviceJump() {
 
   var Current 	= document.frmServices.services.selectedIndex;
   var currentValue 	= document.frmServices.services.options[Current].value;

   window.location.href = currentValue
 
}

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.harrods.com
2. Click on one of the links above the image or choose an option from the drop down
3. Watch the same page (image?) reload over again.

Actual Results:  Image isn't replaced when new page loads

Expected Results:  new image should replace old one so that navigation can continue.

This works on NS4.x, IEW32, konqueror but the fonts look horrible on NS4 and
konqueror... I need my tea!!! :-(
this worksforme with build 2001-06-25-08 and with a CVS build from 2001-06-25-09
or so.
(Reporter)

Comment 2

17 years ago
YACS (yet another cookies site)... *sigh* If I start accepting cookies from the
site it works on 2001062609/Linux.
Marking WFM :-\
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.