[Call log] Tapping on a missed call from a contact is shown black screen

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: isabelrios, Unassigned)

Tracking

unspecified
x86_64
Windows 7
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 757375 [details]
When tapping on a missed call

Bug seen on Unagi today's v1-train:
Gecko-3a432e0
Gaia-cb6d912

PROCEDURE
Receive a call on Unagi device, do not answer or reject it.
Go to Dialer, open Call log.
Tap on the missed call under All label

EXPECTED
A dialog is open giving the options to Call, Create as a new contact, Add to an existing contact.

ACTUAL
A black screen with red header is shown instead.
See screenshot attached.
(Reporter)

Comment 1

5 years ago
I am sorry, the expected is wrong. When tapping on the missed call, the contact detail screen should be shown with the phone number in highlighted.
(Reporter)

Comment 2

5 years ago
It seems that if you wait enough, after the black screen, the contact detail screen is shown correctly.
But anyway the black screen is not expected to be shown and if user does not wait enough looks like it is not working.
Hi! This is a consequence of the patch provided so far for bug 869903 :-O
Depends on: 869903

Comment 4

5 years ago
fixed by backout
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 5

5 years ago
It is reproduced in leo device
blocking-b2g: leo? → leo+

Updated

5 years ago
status-b2g18: --- → fixed

Updated

5 years ago
Flags: in-moztrap?
(Reporter)

Comment 6

5 years ago
This is in Moztrap: #5789 
Dialer suite. owd-2549
Flags: in-moztrap? → in-moztrap+

Comment 7

4 years ago
Issue do not reproduces on Leo device.
 
Build ID: 20130806071254
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 4c1a20570e20f64782ba170c14604395c48f7381
Platform Version: 18.1

when top on the missed call it takes to to the screen where you can call, create new contact and add to exiting contact, not showing black screen
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.