XML Parsing Error: mismatched tag. Expected: </img>.

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: marvinhk, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 757396 [details]
screen capture of the error

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130528181031

Steps to reproduce:

subscribe to rss <http://www.supplymanagement.com/public-sector-purchasing.xml> and display the rss feed as webpage


Actual results:

XML Parsing Error: mismatched tag. Expected: </img>.
Location: http://www.supplymanagement.com/news/2013/procurement-saves-uk-government-38-billion/
Line Number 137, Column 353: <div class="internalAd"><div style="width:240px; height:80px; border:5px solid #C6C6C5; background-color:#FFFFFF; margin:0; padding:0;"> <div style="width:80px; height:80px; border:0; float:left;"><a href="http://jobs.supplymanagement.com"><img src="http://www.supplymanagement.com/EasysiteWeb/getresource.axd?AssetID=151205" border="0"></a></div> <div style="width:152px; height:74px; border:0; float:right; padding:3px; background:url(http://www.supplymanagement.com//EasysiteWeb/getresource.axd?AssetID=151204) no-repeat bottom right"><a href="http://jobs.supplymanagement.com" style="text-decoration:none"><p style="font:13px Arial, Helvetica, sans-serif; color:#000000; margin:0x 0 0 20px;" align="left">Visit our new jobsite<br/>and check out</p></a><a href="http://jobs.supplymanagement.com" style="text-decoration:none"><p style="font:bold 13px Arial, Helvetica, sans-serif; color:#f2bc00; background-color:#000000; margin: 0 53px 0 0; text-align:left;">HUNDREDS OF</p></a><a href="http://jobs.supplymanagement.com" style="text-decoration:none"><p style="font:bold 13px Arial, Helvetica, sans-serif; color:#f2bc00; background-color:#000000; margin:2px 35px 10px 0px; text-align:left;">LIVE VACANCIES</p></a></div> </div></div>


Expected results:

webpage should be loaded and rendered correctly.

Comment 1

5 years ago
But the problem is also in the webpage. It is declared as XHTML (transitional) but is missing the closing of the <img> tag. Notice on lines before 137 all img tags are written as <img /> but the one at line 137 isn't.

So it depends on the mode TB is using to parse the webpage (if it is some strict standards compliance mode). Maybe it is more strict that even Firefox, that does not report the error.

From the error it looks TB uses the XML parser, which really can't accept this error. I don't know if this is intentional, or could be changed to match Firefox.
Component: Untriaged → Feed Reader
Product: Thunderbird → MailNews Core

Comment 2

5 years ago
Imo this is invalid, the web page is in error, regardless of whether Fx is lenient in correcting for the XHTML.  And it's not specific to feeds; the same page opened in a content tab results in the same error.  Not sure what a good component is though.
Component: Feed Reader → Backend
(Reporter)

Comment 3

5 years ago
understood the problem with the XHTML too, just think improving the fault tolerence will make TB better (and this is probably why Fx allows the page to be processed).

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.