Closed Bug 878797 Opened 6 years ago Closed 6 years ago

Sync languages_all.json between v1-train and master

Categories

(Firefox OS Graveyard :: Gaia, defect)

defect
Not set

Tracking

(b2g18 fixed)

RESOLVED FIXED
Tracking Status
b2g18 --- fixed

People

(Reporter: flod, Assigned: flod)

Details

Attachments

(1 file)

Master has currently 63 languages, while v1-train has only 45. These files should have the same content.
Comment on attachment 757400 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10162/files

Errata corrige: master 61 locales, v1-train 46 locales (missing 15 locales).
Attachment #757400 - Flags: review?(stas)
Comment on attachment 757400 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10162/files

r=me on commit 76c8694.
Attachment #757400 - Flags: review?(stas) → review+
Comment on attachment 757400 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10162/files

Hal, just to make sure, is it OK for us to add these locales to locales/languages_all.json on v1-train?  I remember you saying that langauges_all.json is the only file that is safe to edit.

I'd like to see these locales in *localizer* builds here:  http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-b2g18/
Attachment #757400 - Flags: feedback?(hwine)
Comment on attachment 757400 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10162/files

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: none, it's languages_all.json which isn't used in production builds
Testing completed: none
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch:  none

All localizations track v1-train, so this patch merely brings the config file up to date.  In the future, we will make sure that master's and v1-train's lists of languages stay in sync.
Attachment #757400 - Flags: approval-gaia-v1?(21)
(In reply to Staś Małolepszy :stas from comment #4)
> Comment on attachment 757400 [details]
> Pointer to Github pull request:
> https://github.com/mozilla-b2g/gaia/pull/10162/files
> 
> Hal, just to make sure, is it OK for us to add these locales to
> locales/languages_all.json on v1-train?  I remember you saying that
> langauges_all.json is the only file that is safe to edit.

Yes, changing locales/languages_all.json only affects the desktop localizer builds.

> 
> I'd like to see these locales in *localizer* builds here: 
> http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-b2g18/

They should show up the same way every other locale does :)
Comment on attachment 757400 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10162/files

feedback in comment #6
Attachment #757400 - Flags: feedback?(hwine) → feedback+
Attachment #757400 - Flags: approval-gaia-v1?(21) → approval-gaia-v1+
Fixed on v1-train.  Thanks, flod, for the patch, and Hal and Lukas for reviews!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.