[SMS] When focusing the input area, the cursor position should not be lost to the scroll

VERIFIED FIXED

Status

Firefox OS
Gaia::SMS
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: gnarf, Assigned: kaze)

Tracking

unspecified
x86
Mac OS X
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I'm not sure if we want to do something about this.

Steps:
* Add two or three images
* tap on the bottom of the message to start typing text

Expected:
* You can see where you will be typing

Actual:
* Because the height of the box changes, the cursor is well below the scrollable area

----

if you type anything, the scroll is updated correctly

I think we could detect where the focus is and update the scrollTop when we do this
(Reporter)

Updated

5 years ago
Summary: [SMS] When focusing the input area, the cursor position can be lost to the scroll → [SMS] When focusing the input area, the cursor position should not be lost to the scroll
(Reporter)

Updated

5 years ago
Depends on: 877776
Must fix. Not acceptable to have to type blind.
blocking-b2g: --- → leo+
(Assignee)

Updated

5 years ago
Assignee: nobody → kaze
(Assignee)

Comment 2

5 years ago
I can’t reproduce this bug with the master branch. Maybe it’s been fixed along with bug 877776…

Naoki, Mike, can you confirm this bug still occurs?
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(mike)
The patch for bug 877776 helped us identify this as a previously-existing problem.  As it stands, I can still reproduce on `master` (93cfac235cba8c4131da71386a56f23ddb60fb61).
Flags: needinfo?(mike)
(Assignee)

Comment 4

5 years ago
Thanks Mike. I saw the container size issue, working on it.
Flags: needinfo?(nhirata.bugzilla)
(Assignee)

Comment 5

5 years ago
Ugh, the container issue I was referring to was described… and fixed in bug 877683.
(Assignee)

Updated

5 years ago
Depends on: 877683

Comment 6

5 years ago
(In reply to Dietrich Ayala (:dietrich) from comment #1)
> Must fix. Not acceptable to have to type blind.

yep must fix form a UX perspective as well. Can you also ensure that you put me on CC for any bugs that are opened regarding the messaging (SMS or MMS) app please.

Thanks
(Assignee)

Comment 7

5 years ago
Created attachment 758711 [details]
link to pull request

https://github.com/mozilla-b2g/gaia/pull/10221
Attachment #758711 - Flags: review?(mike)
(Reporter)

Comment 8

5 years ago
Comment on attachment 758711 [details]
link to pull request

I really still don't understand the magic number issue in the comments.  Could you try again to explain why you can't just assign scrollTop a value you get from the clientRect?
Attachment #758711 - Flags: review?(mike) → review?(gnarf37)
(Assignee)

Comment 9

5 years ago
Corey, I’ve just updated the pull request according to your suggestions, please have another look.
(Reporter)

Comment 10

5 years ago
Comment on attachment 758711 [details]
link to pull request

Thanks! This works as expected, and has less magic numbering than we started with :)

r=me
Attachment #758711 - Flags: review?(gnarf37) → review+
(Reporter)

Comment 11

5 years ago
master: https://github.com/mozilla-b2g/gaia/commit/8c5c7bac8b1895033ea7e9956453335db4d6aa97
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Flags: in-moztrap?
Uplifted 8c5c7bac8b1895033ea7e9956453335db4d6aa97 to:
v1-train: b7ee2e483098696ebf873f93edbdc4f24bccbdd8
status-b2g18: --- → fixed

Updated

5 years ago
Flags: in-moztrap? → in-moztrap+

Comment 13

5 years ago
Added SMS Suite Test Case #8563 [SMS] The text cursor remains visible while focusing on the SMS attachment input area

Comment 14

4 years ago
The user is able to see the cursor while focusing on the SMS input area.
Issue seems to be fixed so changing to verified fixed.

Environmental Variables
Leo Build ID: 20130807071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/11bb1b0eefff
Gaia: 60ca81600a080dae33058b0692ecaa213556c926
Platform Version: 18.1
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.