Re-enable to-element-width double-tap zooming even without reflow

RESOLVED DUPLICATE of bug 878931

Status

Firefox for Android Graveyard
Readability
RESOLVED DUPLICATE of bug 878931
5 years ago
3 years ago

People

(Reporter: jwir3, Assigned: jwir3)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
When double-tap-to-reflow-text is enabled, and the reflow-on-zoom logic in browser.js has determined that we're already at a sufficiently large enough zoom to achieve the desired font size, double-tap does nothing. Instead, we should re-enable the behavior we previously had (and have with double-tap-to-reflow disabled) where it zooms to the element width, but does not reflow the text.
(Assignee)

Comment 1

5 years ago
Created attachment 761679 [details] [diff] [review]
b878928
Attachment #761679 - Flags: review?(bugmail.mozilla)
As per our last IRC discussion, the patch on this bug depends on the patch on bug 878931.
Depends on: 878931
Comment on attachment 761679 [details] [diff] [review]
b878928

Also, dropping review flag for now, based on the last IRC conversation (sorry I missed your ping yesterday evening). I don't understand why getZoomToMinFontSize returns 1.0 + stuff instead of just the "stuff", and without understanding that I can't review this patch properly.
Attachment #761679 - Flags: review?(bugmail.mozilla)
(Assignee)

Comment 4

5 years ago
Changed were baked into bug 878931, which has now landed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 878931
Product: Firefox for Android → Fennec Graveyard
You need to log in before you can comment on or make changes to this bug.