If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox runs in a hidden background with metrotestharness

RESOLVED FIXED in Firefox 24

Status

Firefox for Metro
Tests
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: AndreeaMatei, Assigned: jimm)

Tracking

Trunk
Firefox 24
All
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-automation-blocked])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
When running the latest metrotestharness uploaded in bug 845079, with the script attached or directly with -firefoxpath, I get the console and the task manager showing nightly is running, but nothing is visible up-front.

This is happening on 2 vm's, mine is with Win 8 32bit, it's a Intel(R) Core(TM) i3 CPU M 370 @ 2.40GHz.

Also tried with an old harness and it's the same behaviour.
Opening metro via the start screen works fine though.
I wish we can get this sorted out and fixed soon given that it blocks our work for this week. Jim, do you have any ideas what could going on here?
Depends on: 845079
(Assignee)

Comment 2

4 years ago
What vm software are you using?
(Assignee)

Comment 3

4 years ago
(In reply to Henrik Skupin (:whimboo) from comment #1)
> I wish we can get this sorted out and fixed soon given that it blocks our
> work for this week. Jim, do you have any ideas what could going on here?

I'm sure it has something to do with this call - 

http://mxr.mozilla.org/mozilla-central/source/browser/metro/shell/testing/metrotestharness.cpp#218

although what the problem is I'm not sure. As I mentioned on irc, we haven't seen this on stand alone installs.
(Assignee)

Comment 4

4 years ago
Does this only happen on 32-bit windows or does it also happen on 64-bit? :whimboo, what version of win8 were you using that worked?
I for myself using VirtualBox via a Ubuntu 13.04 host. It's a Windows 8 64bit VM. I will let Andreea and Andrei speak about their setup, which I don't know.

Andreea or Andrei, can one of you please c&p the console output of metrotestharness.exe as comment to this bug? Don't run mozmill which would only clutter the output.

Comment 6

4 years ago
Virtualbox on OSX host, Windows 8 32 bit, getting a console output now.

Comment 7

4 years ago
Console output:

> $ c:\\work\\metro\\metrotestharness.exe -firefoxpath c:\\Mozilla\\Nightly\\firefox\\firefox\\firefox.exe                                                        INFO | metrotestharness.exe | Launching browser...
> INFO | metrotestharness.exe | App model id='5E0166A20602B51E'
> INFO | metrotestharness.exe | Harness process id: 5748
> INFO | metrotestharness.exe | Using bin path: 'c:\Mozilla\Nightly\firefox\firefox\firefox.exe'
> INFO | metrotestharness.exe | Writing out tests.ini to: 'c:\Mozilla\Nightly\firefox\firefox\tests.ini'
> INFO | metrotestharness.exe | Browser command line args: 'c:\Mozilla\Nightly\firefox\firefox\firefox.exe'
> INFO | metrotestharness.exe | Activation succeeded. processid=5452
> INFO | metrotestharness.exe | Waiting on child process...
> XRE_MetroCoreApplicationRun: IsMainThread:0 ThreadId:150C
> mozilla::widget::winrt::FrameworkView::FrameworkView
> mozilla::widget::winrt::MetroApp::CreateView
> mozilla::widget::winrt::FrameworkView::Initialize
> mozilla::widget::winrt::FrameworkView::SetWindow
> mozilla::widget::winrt::FrameworkView::OnActivated
> Activation argument kind: Launch
> mozilla::widget::winrt::FrameworkView::Run
> mozilla::widget::winrt::MetroApp::Initialize: IsMainThread:0 ThreadId:1544
> XPCOM startup initialization began
> MetroAppShell::Init
> MetroWidget::Create
> eWindowType_invisible window requested, this doesn't actually exist!
> MetroWidget::GetDPI
> MetroWidget::Create
> mozilla::widget::winrt::MetroApp::SetBaseWidget: IsMainThread:1 ThreadId:1544
> mozilla::widget::winrt::FrameworkView::SetWidget
> MetroWidget::FindMetroWindow
> MetroWidget::GetDPI
> MetroWidget::GetDPI
> MetroWidget::GetDPI
> MetroWidget::GetDPI
> ### Content.js loaded
> ### FormHelper.js loaded
> ### SelectionHandler.js loaded
> ### ContextMenuHandler.js loaded
> ### FindHandler.js loaded
> ### ConsoleAPIObserver.js loaded
> MetroWidget::GetDPI
> MetroAppShell::Run
> XPCOM startup initialization complete
> mozilla::widget::winrt::FrameworkView::SetupContracts
> MetroWidget::GetDPI
> mozilla::widget::winrt::MetroInput::MetroInput
> mozilla::widget::winrt::FrameworkView::AddEventHandlers hr=0
> MetroWidget::GetDPI
> * delay load started...
> * delay load complete.
> INFO | metrotestharness.exe | Exiting.
> INFO | metrotestharness.exe | Deleting c:\Mozilla\Nightly\firefox\firefox\tests.ini
(In reply to Andrei Eftimie from comment #7)
> > INFO | metrotestharness.exe | Browser command line args: 'c:\Mozilla\Nightly\firefox\firefox\firefox.exe'

This looks suspicious and we should not get the binary as command line option for the browser.
Whiteboard: [qa-automation-blocked]
(Assignee)

Comment 9

4 years ago
(In reply to Henrik Skupin (:whimboo) from comment #8)
> (In reply to Andrei Eftimie from comment #7)
> > > INFO | metrotestharness.exe | Browser command line args: 'c:\Mozilla\Nightly\firefox\firefox\firefox.exe'
> 
> This looks suspicious and we should not get the binary as command line
> option for the browser.

Yes you should, that's what bug 878208 added.
(Assignee)

Comment 10

4 years ago
(In reply to Andrei Eftimie from comment #6)
> Virtualbox on OSX host, Windows 8 32 bit, getting a console output now.

Kind of a long shot work around but you might try upgrading to 64-bit Windows.

Comment 11

4 years ago
I see the same behaviour on a newly installed 64-bit Windows 8.
Same VirtualBox Host instance, so I'll check messing with those settings a bit.
(Reporter)

Comment 12

4 years ago
I have discovered that right after I give the command, if I click somewhere else in order to lose focus from the console, it switches to the browser.
Also, if I run the harness in the windows console, it works. Most likely is something with the mozmill setup, but it's strange cause we did the same steps as Henrik and for him it works.
(Assignee)

Comment 13

4 years ago
(In reply to Andreea Matei [:AndreeaMatei] from comment #12)
> I have discovered that right after I give the command, if I click somewhere
> else in order to lose focus from the console, it switches to the browser.
> Also, if I run the harness in the windows console, it works. Most likely is
> something with the mozmill setup, but it's strange cause we did the same
> steps as Henrik and for him it works.

With henrick we ran into a different problem and had to modify the code in the harness somewhat, so there must be some model differences here between your two set ups.

Regardless I think I can improve this a bit more for your case based on your test results. Will post a new rev after I test a bit.
(Assignee)

Comment 14

4 years ago
Created attachment 758483 [details] [diff] [review]
metrotestharness.exe

Here's a new rev of the harness for testing which ignores failures to hand off focus rights. Hopefully this will get around your terminal issues in vms and still manage to launch the browser. Please let me know if you still have issues.
Assignee: nobody → jmathies
(Assignee)

Comment 15

4 years ago
Created attachment 758485 [details] [diff] [review]
fix

Comment 16

4 years ago
Thanks Jim,

This fixes the issue for me, works like a charm!
(Reporter)

Comment 17

4 years ago
It's working for me too. Thanks!
(Assignee)

Comment 18

4 years ago
Comment on attachment 758485 [details] [diff] [review]
fix

Simplifying this even more. Seems to be working for everyone.
Attachment #758485 - Flags: review?(netzen)
Comment on attachment 758485 [details] [diff] [review]
fix

Review of attachment 758485 [details] [diff] [review]:
-----------------------------------------------------------------

I just did the same thing on oak for testing updates.
Attachment #758485 - Flags: review?(netzen) → review+
(Assignee)

Comment 20

4 years ago
Created attachment 759080 [details] [diff] [review]
export patch
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
OS: Windows 8 → Windows 8 Metro
Version: unspecified → Trunk
https://hg.mozilla.org/integration/mozilla-inbound/rev/e7d7d70be102
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e7d7d70be102
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.