Closed Bug 879128 Opened 9 years ago Closed 9 years ago

Remove blocklist on new Avid Scorch 6.2.0b89

Categories

(Toolkit :: Blocklist Policy Requests, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
2013-06-13

People

(Reporter: michael.ost, Assigned: jorgev)

References

Details

Attachments

(1 file)

Avid Scorch 6.2.0 is blocklisted in Firefox 18 and later. We have a new version 6.2.0b89 under test which works around the crash. Two requests:

1. Please turn off blocklisting for our newer version.
2. Please point users to www.sibelius.com/scorch/firefox_support if the old version is detected. We will put update instructions there.

Note: we have restrictions from our publisher partners that prevents us from updating the version to 6.2.1, so we're stuck with adding the build number (89) to the version. I hope you can accomodate that.

The plugin was originally blocklisted under bug 829054
If you can provide the exact format of the plugin description and version fields, we can probably accomplish this. Providing an installer for testing (privately if necessary) will help with staging verification also.
Blocks: 829054
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(michael.ost)
Attached image Avid Scorch in Firefox
Shows the description and version for the new Scorch plugin, version 6.2.0b89
Flags: needinfo?(michael.ost)
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> fields, we can probably accomplish this. Providing an installer for testing
> (privately if necessary) will help with staging verification also.

I'd be happy to provide the installer. It's about 6.5MB. Should it be attached to the bug, or delivered some other way?
dropbox/google drive link, perhaps? 6.5MB is too big for bugzilla.

Getting the blocklist rules right for this is going to be tough, since our normal comparison rules treat "6.2.0b89" as a beta build which is "less than" 6.2.0.

What will your versioning scheme be for future updates? Will they eventually become 6.2.1 or larger numbers, or will just the build number be incremented?
I can modify the current block so it covers 0-6.2.0b88 and then add a new block for 6.2.0 alone.

However, as Benjamin asked, we nee to know what you versioning plan is, since this is going to make it very difficult to manage potential blocks in the future.
Assignee: nobody → jorge
(In reply to Jorge Villalobos [:jorgev] from comment #5)
> I can modify the current block so it covers 0-6.2.0b88 and then add a new
> block for 6.2.0 alone.
> 
> However, as Benjamin asked, we nee to know what you versioning plan is,
> since this is going to make it very difficult to manage potential blocks in
> the future.

I apologize for the strange version change. We are trying hard to minimize the impact of this change on our organization and our publishing partners. But, I promise that future versions would have more normal change to the version next time.

I emailed Benjamin Smedberg about a google drive link to the installer. Since it isn't a release candidate it needs to remain private. If anyone else wants access please send me an email at michael.ost@avid.com.

(PS: sorry for the delayed response. I'm not sure why my entries in this bug db haven't been "taking". I know I typed this message up earlier. Probably user error...)
ok Jorge, let's proceed with two separate blocks, one from 0-6.2.0b88 and one for 6.2.0 only. Anthony, I'll send you the installer link for QA verification.
QA Contact: anthony.s.hughes
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #7)
> one for 6.2.0 only. Anthony, I'll send you the installer link for QA
> verification.

How long should I keep that link "live" for?

Thanks for the help!
The blocks have been staged.
Keywords: qawanted
(In reply to Jorge Villalobos [:jorgev] from comment #9)
> The blocks have been staged.

Not sure about the lingo. Does this mean they are public, or only internal to mozilla?
For now the changes are internal, so we can test them. If you like, you can test the changes following these instructions: https://wiki.mozilla.org/Blocklisting/Testing
(In reply to Jorge Villalobos [:jorgev] from comment #11)
> For now the changes are internal, so we can test them. If you like, you can
> test the changes following these instructions:
> https://wiki.mozilla.org/Blocklisting/Testing

I tried this with my 6.2.0b89 version and it works! Thanks.

about:plugins shows it as 'disabled' though. Is the user required to enable the plugin via Add-Ons Manager/Plugins. It would be a drag to have to explain that to customers (who are already confused!).
I don't think it's supposed to show up as user-disabled in that case, but I'll bet we don't test that case very often.
We are eager to push the new installer out to beta testers and would like to do so tomorrow. Any ETA on making the changes live? Thanks.
(In reply to Michael Ost from comment #14)
> We are eager to push the new installer out to beta testers and would like to
> do so tomorrow. Any ETA on making the changes live? Thanks.

QA is still not completed and I can't promise it will be done by tomorrow at this point.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #15)
> QA is still not completed and I can't promise it will be done by tomorrow at
> this point.

Just to clarify, we'll make every effort to get this done ASAP and this may very well be done in time to push live tomorrow but I cannot make that promise.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #16)
> (In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #15)
> > QA is still not completed and I can't promise it will be done by tomorrow at
> > this point.
> 
> Just to clarify, we'll make every effort to get this done ASAP and this may
> very well be done in time to push live tomorrow but I cannot make that
> promise.

Thanks! I appreciate your attention to this.

It might not have been clear but there were two requests in the description. (1) unblocking the newer 6.2.0b89 version and (2) providing a helpful link for the old broken 6.2.0 version. On the dev blocklist server I can confirm that (1) works, but I don't see any evidence of (2) being done.
(In reply to Michael Ost from comment #17)
> (In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #16)
> > (In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #15)
> > > QA is still not completed and I can't promise it will be done by tomorrow at
> > > this point.
> > 
> > Just to clarify, we'll make every effort to get this done ASAP and this may
> > very well be done in time to push live tomorrow but I cannot make that
> > promise.
> 
> Thanks! I appreciate your attention to this.
> 
> It might not have been clear but there were two requests in the description.
> (1) unblocking the newer 6.2.0b89 version and (2) providing a helpful link
> for the old broken 6.2.0 version. On the dev blocklist server I can confirm
> that (1) works, but I don't see any evidence of (2) being done.

Jorge, can you make sure there's a link to the plugin update instructions included in the blocklist page?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #18)
> Jorge, can you make sure there's a link to the plugin update instructions
> included in the blocklist page?

Yes. I just updated the staged block pages to link to the page in comment #0: https://addons-dev.allizom.org/en-US/firefox/blocked/p341

Michael, please note that the URL is 404 at the moment.
(In reply to Jorge Villalobos [:jorgev] from comment #19)
> Michael, please note that the URL is 404 at the moment.

Jorge, is it possible to change that to http://www.sibelius.com/support/scorch/firefox.html? I missed the tail end of an email thread and sent you the wrong address. If not, we can redirect but it would be great if you could. Thanks.
I updated the URL in the staged blocks.
QA has finished testing and here are our results.

1. https://addons-dev.allizom.org/en-US/firefox/blocked/p248 includes a link to http://www.sibelius.com/support/scorch/firefox.html
2. Current version remains blocked for Firefox 21 through 24.0a1
3. New version is not blocked for Firefox 21 through 24.0a1
4. New version does not reproduce the crash from bug 828216

The only issue found was that this new version of the plugin causes Firefox to freeze on Mac OSX 10.6 and 10.7 under the circumstances of bug 828216; Mac OSX 10.8 seems to be unaffected. I cannot confirm how serious this hang is yet since I don't have a Mac 10.6/10.7 machine in front of me right now. 

I'd be a bit concerned pushing this updated blocklist live knowingly introducing a potential hang to some subset of users.
Keywords: qawanted
Benjamin, thoughts on comment #22?
Flags: needinfo?(benjamin)
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #22)
> The only issue found was that this new version of the plugin causes Firefox
> to freeze on Mac OSX 10.6 and 10.7 under the circumstances of bug 828216;
> Mac OSX 10.8 seems to be unaffected. I cannot confirm how serious this hang
> is yet since I don't have a Mac 10.6/10.7 machine in front of me right now. 
> 
> I'd be a bit concerned pushing this updated blocklist live knowingly
> introducing a potential hang to some subset of users.

Good catch!

We will be doing testing of a slightly newer installer on 10.6 and 10.7 on Monday. I'll let you know how that goes and post it to you if it fixes the problem.

BTW - the blocklisting is a little less urgent than I thought. It turns out with FF21 (for instance) a beta tester can just manually enable the blocklisted Scorch and use it. So our beta testing is blocked by this bug. That was why I was feeling urgency about this issue.
Let us then wait on deploying the new blocks until Avid can test the freeze reported in comment 22 and fix it if it's reproducible.
Flags: needinfo?(benjamin)
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #25)
> Let us then wait on deploying the new blocks until Avid can test the freeze
> reported in comment 22 and fix it if it's reproducible.

Crashes in 10.6 and 10.7 are fixed. The installer is in the dropbox folder shared earlier, as ScorchInstall620b89_67.pkg. BTW - this is looking like our release candidate.
We need to test this again with the staged block.
Keywords: qawanted
During the Release Coordination meeting we decided testing wasn't necessary to push this block, so it is coming up.
Keywords: qawanted
Done.

Updated: https://addons.mozilla.org/en-US/firefox/blocked/p248
New block: https://addons.mozilla.org/en-US/firefox/blocked/p366
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
All works for us. Thanks everyone!
Target Milestone: --- → 2013-06-13
The two blocks contain a link to a page that advices to downgrade Firefox to version 17.0.2esr (not recommended for individual users): https://addons.mozilla.org/firefox/blocked/p248, https://addons.mozilla.org/firefox/blocked/p366
The link should be http://www.sibelius.com/products/scorch/index.html in order to upgrade Scorch to version 6.2.
I've taken down the links from the blocklist entries. 6.2 is also blocked, so there's no use pointing users to install it.
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.