[Settings] WPS connection status not updated

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: juanpbf, Assigned: kaze)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed, b2g-v1.1hd fixed)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 757873 [details]
Screenshot: Terminal attached to network B. Wrong WPS connection status

Seen on Ikura, 

QC RIL version:
"ro.build.firmware_revision=V1.01.00.01.019.120"
gaia commit:
50abeb2 Merge pull request #10032 from alivedise/bugzilla/872912_v1.0.1b
gecko commit:
a6a5487 Bug 875483 - YouTube HTML5 Playback hangs Firefox. r=derf,a=tef+

After being connected to a WPS network, when you connect to a new NW without manually disconnecting first from the previous one, the Wifi settings page still shows as if you were connected to the first one

STEPS TO REPRODUCE
1 - Connect the handset to a Wi-Fi network (A) with WPS 
2 - Afterwards connect it to another Wi-Fi network (B), 
3 - The status of connection shown in the Wifi Settings page is:

Connect with WPS
Connected with Wi-Fi Network A

Networks available:
Wi-Fi Network B
Connected

EXPECTED RESULT:
The WPS information must refresh once the terminal connects to a different network.

Please check the pictures attached in following comments.
(Reporter)

Comment 1

5 years ago
Created attachment 757874 [details]
Screenshot: Terminal connecting to network B. Wrong WPS connection status
(Reporter)

Comment 2

5 years ago
Created attachment 757875 [details]
Screenshot: Terminal not connected to any wifi network. Wrong WPS connection status

Updated

5 years ago
blocking-b2g: --- → tef?

Comment 4

5 years ago
The vendor has raised this as a potential IOT blocker. Setting tef? to get this triaged.

Updated

5 years ago
blocking-b2g: tef? → tef+
(Assignee)

Comment 5

5 years ago
Rushing to buy a WPS router right now…
Assignee: nobody → kaze
Kaze takes it for urgent investigation
(Assignee)

Comment 7

5 years ago
Created attachment 759126 [details]
link to pull request

https://github.com/mozilla-b2g/gaia/pull/10242
Attachment #759126 - Flags: review?(anthony)
(Assignee)

Comment 8

5 years ago
I found a few other issues regarding this WPS connection status…

 • By default, the subtitle doesn’t fit in the line (in English): “Automatic wireless network configuration” is truncated; we probably should use a shorter string (which would result in shorter strings for other locales). Francis, would you have a suggestion here?

 • When the Settings app first starts, if we’re already connected to a network because it’s been associated with WPS, the status line below “Connect with WPS” won’t say “Connected to [network]” — the default string will be used instead (“Automatic wireless network configuration”).

Suggestion: maybe this WPS status line should only display information on *ongoing* WPS operations — “Connecting…”, “Obtaining an IP address…”, etc.
As soon as the WPS connection is done (or has failed), the related network item in the list below will be highlighted in blue and will display its own status string (e.g. “Connected” or error) —  so I think we could clear the WPS connection status line as soon as a network is connected and reset it to the default status string.

Daniel, Francis, would that make sense to you?
Flags: needinfo?(firefoxos-ux-bugzilla)
I think your proposal makes a lot of sense

Comment 10

5 years ago
Assigning to Rob, tef+.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(rmacdonald)
(In reply to Fabien Cazenave [:kaze] from comment #8)
> I found a few other issues regarding this WPS connection status…
> 
>  • By default, the subtitle doesn’t fit in the line (in English): “Automatic
> wireless network configuration” is truncated; we probably should use a
> shorter string (which would result in shorter strings for other locales).
> Francis, would you have a suggestion here?

Would "Automatic Wi-Fi setup" work? Also, should we include the WPS logo? 

One more point, after tapping the link, the words "Wi-Fi Protected Setup" are also truncated in the header. Perhaps this should be replaced with just "WPS"?

Please flag Francis or I with your comments.
Flags: needinfo?(rmacdonald)
(Assignee)

Comment 12

5 years ago
(In reply to Rob MacDonald [:robmac] from comment #11)
> Would "Automatic Wi-Fi setup" work? Also, should we include the WPS logo? 

I guess “Automatic Wi-Fi setup” would work.

Including the logo might help but I’m not sure how to do it:
 • if we put the logo on the left, we break the consistency and the vertical alignment;
 • if we put it on the right, the logo should indicate a status rather than describing the item itself (there’s been a discussion with Josh about that in the past).

So my suggestion would be to have a status icon on the right:
 • by default, the WPS icon would be still;
 • when the WPS connection is in progress, the WPS icon would be animated until the connection is established (or failed).

> One more point, after tapping the link, the words "Wi-Fi Protected Setup"
> are also truncated in the header. Perhaps this should be replaced with just
> "WPS"?

“in the header” == on the main (root) panel?
The Wi-Fi subtitle in the main panel is a copy of the Wi-Fi connection status in the Wi-Fi subpanel: if this status is truncated in the subpanel, it will be truncated in the root one — in fact it will be a bit more truncated, as the items in the root panel are a bit less wide than the ones in subpanels.
Flags: needinfo?(rmacdonald)
(Assignee)

Comment 13

5 years ago
(In reply to Rob MacDonald [:robmac] from comment #11)
> One more point, after tapping the link, the words "Wi-Fi Protected Setup"
> are also truncated in the header. Perhaps this should be replaced with just
> "WPS"?

Oh, I just got it, sorry for the confusion.

Yes, you’re right: “WPS” alone should be enough in this context.
(Assignee)

Comment 14

5 years ago
Created attachment 760158 [details]
link to pull request — proper fix

https://github.com/mozilla-b2g/gaia/pull/10278/files

Comments have been addressed; if we get a WPS status icon it can be added to this pull request — we can also open another bug for that.

(In reply to Fabien Cazenave [:kaze] from comment #13)
> (In reply to Rob MacDonald [:robmac] from comment #11)
> > One more point, after tapping the link, the words "Wi-Fi Protected Setup"
> > are also truncated in the header. Perhaps this should be replaced with just
> > "WPS"?
> Yes, you’re right: “WPS” alone should be enough in this context.

Actually I’ve used “Connect with WPS” instead, as it’s the label of the link that leads to this sub-panel. That’s consistent with the rest of the Settings UI.
Attachment #759126 - Attachment is obsolete: true
Attachment #759126 - Flags: review?(anthony)
(Assignee)

Updated

5 years ago
Attachment #760158 - Flags: review?(ehung)
(Assignee)

Updated

5 years ago
Summary: WPS connection status not updated → [Settings] WPS connection status not updated

Comment 15

5 years ago
Clearing Rob's needinfo since it looks like his comments were sufficient. Please needinfo? firefoxos-ux if this needs any additional UX help.
Flags: needinfo?(rmacdonald)
(Assignee)

Comment 16

5 years ago
A WPS status icon would help (as suggested in comment #11), that’s why I pinged UX:

(In reply to Fabien Cazenave [:kaze] from comment #12)
> So my suggestion would be to have a status icon on the right:
>  • by default, the WPS icon would be still;
>  • when the WPS connection is in progress, the WPS icon would be animated
>    until the connection is established (or failed).

If you think that we don’t need this icon right now I can open a follow-up; if you think we don’t need such an icon at all, please let me know.
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 17

5 years ago
Thanks for the clarification, Fabien. Rob, please advise on whether or not we need an icon. If so, we'll bump this over to VxD.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(rmacdonald)
Comment on attachment 760158 [details]
link to pull request — proper fix

Stealing the review as Kaze asked me on IRC.

And r+ !
Attachment #760158 - Flags: review?(ehung) → review+
(Assignee)

Comment 19

5 years ago
Thanks Anthony! Merged on master:
https://github.com/mozilla-b2g/gaia/commit/5374d783a27a842a1a82d0293781de4d883f4015

Rob: in case we need an icon, can you please open a follow-up?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
John, can you assist with the uplift please? :)
Flags: needinfo?(jhford)
v1-train: d313671
v1.0.1 had merge conflicts.
status-b2g18: --- → fixed
Flags: needinfo?(jhford) → needinfo?(kaze)
(In reply to Fabien Cazenave [:kaze] from comment #19)
> Thanks Anthony! Merged on master:
> https://github.com/mozilla-b2g/gaia/commit/
> 5374d783a27a842a1a82d0293781de4d883f4015
> 
> Rob: in case we need an icon, can you please open a follow-up?

The icon is more of a "nice to have" and, as a result, be deferred until a future release.
Flags: needinfo?(rmacdonald)
(Assignee)

Comment 23

5 years ago
uplifted to v1.0.1: 898c1d3
https://github.com/mozilla-b2g/gaia/commit/898c1d36cb81c48622c794f17fe7c855c3dc4b73
Flags: needinfo?(kaze)
status-b2g18-v1.0.1: --- → fixed
1.1hd: d313671805187dc736fe4e2af5a2f334f097f36d
status-b2g-v1.1hd: --- → fixed

Comment 25

5 years ago
Issue repros on Inari ID: 20130621070212
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a34f6d62cb05
Gaia: f88249cc452c39abd0768ec65729939fb561eca2
Platform Version: 18.0

The WPS does not refresh when user connects to a different WiFi.  WPS stays the same as the original WiFi it connected too.

Comment 26

5 years ago
disregard comment 25

Issue repros on 
Inari Build ID: 20130621070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
Gaia: 93241eb6c5d6c110710fad8da3ccd4423312b0c9
Platform Version: 18.0

The WPS does not refresh when user connects to a different WiFi.  WPS stays the same as the original WiFi it connected too.
You need to log in before you can comment on or make changes to this bug.