el.tap() not tapping successfully sometimes, but works with target

RESOLVED WONTFIX

Status

Testing
Marionette
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: bsilverberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [touch])

(Reporter)

Description

5 years ago
I am opening this bug because I think it bears investigation, even though we are not sure if this is a marionette issue or not. We have a number of tests where the tap() method has not been successfully tapping on an element. When we change the simple el.tap() call to el.tap(y=(el.size['height'] - 1)) then it fixes the problem. Our initial thought was that the system updates notification was getting in the way of the tap, but there is one test in which the element in question is about halfway down the page, so it doesn't seem like the notification could be overlaying part of the element.

The test in question is at https://github.com/mozilla/gaia-ui-tests/blob/v1.0.1/gaiatest/tests/settings/test_settings_passcode.py.

The test, without the targeting change, only fails intermittently, but if there is some way of checking to see exactly what's happening from marionette's side when the test does fail I think that might be worthwhile, as I fear this is an issue with tap() itself.
(Reporter)

Updated

5 years ago
Blocks: 869034
(Reporter)

Comment 1

5 years ago
I just saw something else in one of the tests affected by this. The test is at [1], with the tap in question being at [2]. When I ran this test (with the targeting removed) and it failed, I noticed that the Next button actually "shifts" a bit, so it looks like it's being interacted with, but the action that is supposed to happen as a result of the tap doesn't take place.

[1] https://github.com/mozilla/gaia-ui-tests/blob/v1.0.1/gaiatest/tests/email/test_setup_basic_gmail.py
[2] https://github.com/mozilla/gaia-ui-tests/blob/v1.0.1/gaiatest/apps/email/regions/setup.py#L32
(Reporter)

Comment 2

5 years ago
After running the above test several times (without targeting), I am seeing failures about 25% of the time. Sometimes the Next button shifts and sometimes it doesn't react in an way, but always with the failure the result of clicking the Next button isn't performed.

To test the overlay theory I tried changing the target to the top of the Next button, rather than the bottom of the Next button, but that didn't fix the problem, which does suggest an overlay issue, but I still don't understand how an element that is nowhere near the element in question (in the case of the switch in the first example in Comment #0) could be interfering with the tap.
I've run the test about 15-20 times with the .tap() change (ie: without a target) and I can't reproduce the problem. It's able to tap the Next button and I don't see any shifting.

I'm on an unagi with today's v1.0.1 build. Can you confirm this is still happening on your end?
Whiteboard: [touch]
Keywords: ateam-marionette-goal, ateam-marionette-userinput
Keywords: ateam-marionette-goal, ateam-marionette-userinput

Comment 4

4 years ago
Haven't seen anything like this error for a very long time.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.