Closed Bug 879328 Opened 7 years ago Closed 4 years ago

partner repack support for Firefox for Android

Categories

(Release Engineering :: Release Automation: Other, defect, P3)

x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1163084

People

(Reporter: bhearsum, Unassigned)

References

Details

Fennec recently regained the ability to have partner repacks. We want to be able to make use of this to make repacks for Yandex (and presumably other things in the future). We need some automation around this before we can ship these with every release.

Details of what constitutes a repack are documented here: https://wiki.mozilla.org/Mobile/Distribution_Files.

It's probably easiest to integrate this with the existing partner repack scripts since they already know how to do things like talk to the signing server.
Should also note that bug 866754 has additional background on this.
The current never-used, needs-updating+testing script was tracked in bug 659544.
Depends on: 659544
(In reply to Aki Sasaki [:aki] from comment #2)
> The current never-used, needs-updating+testing script was tracked in bug
> 659544.

Thanks! That should be really helpful for the unpacking/repacking at the very least. Do you know if partner repacks were implemented the same way back when you wrote that? Based on seeing "partner.js" in the mozharness patch there, it looks like not...
They were not.

I avoided the existing partner repacks script/repo since I felt like they desperately needed to be rewritten, but didn't have the headspace to deal with both Android and rewriting all desktop partner repacks during the Android native launch.
Alex, when do we need this by?
Flags: needinfo?(akeybl)
Product: mozilla.org → Release Engineering
Priority: -- → P3
Blocks: 866754
No longer blocks: 866754
(In reply to Ben Hearsum [:bhearsum] from comment #5)
> Alex, when do we need this by?

We're flying blind on metrics on our end, but nobody's clamoring.

Karen, what do you think in terms of timelines for being able to identify what % of our users are on Google vs Yandex vs T.Store?
Flags: needinfo?(akeybl)
Flags: needinfo?(krudnitski)
Numbers are really small at the moment, and I'd clamour more to get this done quicker if we were tracking these as strong distribution channels (which I don't think will be for a little while). 

Is metrics the only benefit here? If so, could we get this done mid Q4 (so we don't let it slide along too much longer but reflecting a priority that says it's not needed immediately from my side).
Flags: needinfo?(krudnitski)
(In reply to Karen Rudnitski [:kar] from comment #7)
> Is metrics the only benefit here? If so, could we get this done mid Q4 (so
> we don't let it slide along too much longer but reflecting a priority that
> says it's not needed immediately from my side).

That's my understanding. I'll try to find an owner for this for Q4.
Priority: P3 → --
This seems like it isn't much of a priority, and other everyone is working on other important things.
Priority: -- → P3
Is there another way to track the number of users on yandex and tstore, or do we still just do this manually via dev console access through relman & product marketing? Numbers still aren't terribly high so I'm not overly concerned, but just wanted to ensure that A) metrics / tracking users was the driver and B) no other benefits are being lost by deprioritizing.

Note: we are using partner IDs within the distribution files to track ADIs via tableau for our preinstalls, but so far I'm still avoiding any need to use true desktop-like partner repacks for online distribution. This *may* change, but will let you know if it does.
Duping forward to the latest incarnation.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1163084
You need to log in before you can comment on or make changes to this bug.