[B2G ][Camera] Camera launches as a black screen

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Camera
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Sarah Parsons, Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Description:
If the user attempts to launch the Camera app, just a black screen will appear with the camera icon and the user will be unable to take pictures. 

Repro Steps:
1) Updated to Buri Build ID: 20130604070205
2) Open the Camera App.

Actual:
Screen appears black and the user is unable to take pictures.

Expected:
User's environment should display on the screen and they should be able to take pictures. 

Environmental  Variables:
Kernel Date: Mar 15
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/997cdbf5d012
Gaia: 5534304aee934055f08f21ce93261ba2a596516a

Notes:
Repro frequency: 100%
(Reporter)

Comment 1

5 years ago
I should add that this only occurred on the v1.1 Comm rill. The camera on the v1.1 Moz rill works.

Comment 2

5 years ago
Issue is also occurring on an Unagi device running the latest build from the com 1.1 branch:

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/09dc1ae3b1b5
Gaia: 92a6e36957145cdb2ac8867e5cdba8ecf12308fc
Build: 20130605070207

After attempting to take a photo, the camera will go to a black screen and crash shortly after.

Updated

5 years ago
Keywords: regression, smoketest
blocking-b2g: --- → leo?
Unable to reproduce on Inari with:
- gecko: b2g18:09dc1ae3b1b5
- gaia: v1.0.1:37b6527c3f73a497f75d057e90386f77ff5a552b

Updated

5 years ago
Summary: [B2G ][Buri][Camera] Camera launches as a black screen → [B2G ][Camera] Camera launches as a black screen
Unable to reproduce in Unagi DEBUG build with:
- gecko: b2g18:eff45c60396e
- gaia: v1.0.1:37b6527c3f73a497f75d057e90386f77ff5a552b

Comment 5

5 years ago
On Unagi device Build ID: 20130606070207 after pressing camera button you will get normal screen to take picture for about 2 seconds and then it switches to black screen.
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/eff45c60396e
Gaia: 337674ef250cc8a05358b873b0fdbb2e73b49224
Can someone who can reproduce try to narrow down a regression window?
Keywords: regressionwindow-wanted
Mike, it seems like you're trying v1.0.1 and this is occurring on v1.1.
Created attachment 760001 [details]
logcat filtered on camera

Testing with unagi, Mozilla RIL and:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/bb6c9375f53b
Gaia   d85d73e50a82cc665d862a93aa7ab34ec0f861ba
BuildID 20130607070208
Version 18.0

Camera is having issues with a black screen on this device, but I wasn't able to reproduce it on the same build with a different unagi device.

I captured a logcat and it I can reproduce the issue pretty consistently on this phone.

I tested the latest Leo 1.1 build and I haven't been able to reproduce it on that device yet.
Inder, looking through Marcia's log, I see this at the end:

06-07 18:45:26.867: E/QualcommCameraHardware(116):  Camframe timed out. Not receiving any frames from camera driver 

Any idea what's going on here?
Flags: needinfo?(ikumar)

Comment 10

5 years ago
All this says that something went wrong with camera driver. Please share kernel logs as well. Hopefully that will have some more info.
Flags: needinfo?(ikumar)
Marcia, once you've reproduced this problem, you can get the kernel logs by running the command 'adb shell dmesg' on your PC.
Flags: needinfo?(mozillamarcia.knous)
As written, this is a blocker.
blocking-b2g: leo? → leo+
I just tried running the same build again on Unagi, and I wasn't able to reproduce the issue:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/bb6c9375f53b
Gaia   d85d73e50a82cc665d862a93aa7ab34ec0f861ba
BuildID 20130607070208
Version 18.0

However, I am not certain if the phone I have here is same one I was testing with in Comment 8. I would suggest someone in MV try flashing that same build on one of the devices that I have left on my desk to see if they can reproduce.

I am going to flash today's build as well and see the results - the last build I tried to flash the other day failed because of Bug 872120.
Flags: needinfo?(mozillamarcia.knous)
Just flashed 6-12 build and haven't been able to reproduce the issue on unagi device using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/b4f8f0a288ca
Gaia   547db47241459b5944ba40bacc94b15977d8a02e
BuildID 20130612070210
Version 18.0
This wfm on Leo with build from 20130613. Camera app works fine.
Switching to qawanted. Sarah - Can you retest this on the latest build to see if this still reproduces?
Flags: needinfo?(sparsons)
Keywords: regressionwindow-wanted → qawanted
(Reporter)

Comment 17

5 years ago
(In reply to Jason Smith [:jsmith] from comment #16)
> Switching to qawanted. Sarah - Can you retest this on the latest build to
> see if this still reproduces?

Today's 1.1 moz and comm builds for Buri, Leo and today's 1.1 moz build for Unagi do not have the black screen camera issue. 

Build ID: 20130614070213

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/537f3eac4c48
Gaia: ba4c3763514dbb9fd1dd886b4b6f3bff50bad264
Platform Version: 18.0
Okay sounds good. Closing as a works for me then.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(sparsons)
Keywords: qawanted
Resolution: --- → WORKSFORME
Duplicate of this bug: 863962

Comment 20

5 years ago
Created attachment 764214 [details]
dmesg for keon with black screen in camera app

As requested in bug 863962, here is the output from "adb shell dmesg".

Note, I had to reboot my device to get a clean dmesg.  After the reboot, the camera worked.  I took a picture, opened gallery, deleted the picture.  When I next relaunched camera, I got the black screen.  Its unclear to me if this sequence of events is relevant or not.

Comment 21

5 years ago
Created attachment 764217 [details]
Another dmesg for camera failure

This dmesg was for a failure that occurred immediately after boot.
Comment on attachment 764217 [details]
Another dmesg for camera failure

Inder, can you take a quick look at this kernel log for anything suspicious in the camera driver? Nothing stands out to me, but there are some error messages at the end.
Attachment #764217 - Flags: feedback?(ikumar)

Comment 23

5 years ago
It's timing out here: 
https://www.codeaurora.org/cgit/quic/la/kernel/msm/tree/drivers/media/video/msm/msm_camera.c?h=ics_strawberry#n919
Not sure but looks like the camera sensor is not responding? It doesn't have lot of info.
I will ask the camera guys to see if they could infer what is going on but we will need a consistent failure to debug it and we don't see this on any of our devices.

Updated

5 years ago
Attachment #764217 - Flags: feedback?(ikumar)
Duplicate of this bug: 885244

Comment 25

5 years ago
Camera team took a look and pointed out that the error is because it's not able to find mm-qcamera-daemon. See this in the log (Attachment #764217 [details]):
<3>[    3.636901] init: cannot find '/system/bin/mm-qcamera-daemon', disabling 'qcamerasvr'

Please make sure that it's getting built, loaded and running.
(In reply to Inder from comment #25)
> Camera team took a look and pointed out that the error is because it's not
> able to find mm-qcamera-daemon. See this in the log (Attachment #764217 [details]
> [details]):
> <3>[    3.636901] init: cannot find '/system/bin/mm-qcamera-daemon',
> disabling 'qcamerasvr'
> 
> Please make sure that it's getting built, loaded and running.

Inder, is this something new?  I don't think I've ever seen a file named 'mm-qcamera-daemon' anywhere in a build or on a device (nor does it exist on any of my filesystems); and devices that don't have it (such as my inari) seem to have working cameras.
Flags: needinfo?(ikumar)
Resolution: WORKSFORME → FIXED

Comment 27

5 years ago
Strange.. its there on our reference devices. Not sure why you don't see it. Looks like it's there to poll for events from the camera server. I will check with camera team if there are alternate mechanism or something.
Flags: needinfo?(ikumar)

Comment 28

5 years ago
Mike, I did enquiry with camera team about the camera daemon and they pointed out the camera daemon have been around since Gingerbread so it needs to be running. Here is their complete response:

"Till date we have two main camera SW implementations:
 
1.       Native driver based implementation. (Camera daemon not present)
2.       V4L2 based implementation. (Camera daemon present and absolutely essential for camera functionality)
 
So the implementation switch from (1) to (2) happened sometime during GB timeline(I guess around April-May’2011, but not sure of the exact date). So ever since that camera daemon is an essential component and absolutely needed for camera functionality to work. There is no alternative to it.
 
Also please note that we have discontinued support for Native driver based implementation."
mwu, have we ever loaded '/system/bin/mm-qcamera-daemon' onto b2g builds? Until comment 25 above, I've never heard of this file. Inder says we need it.
Flags: needinfo?(mwu)

Comment 30

5 years ago
Yeah we have it on a number of ports. Not all camera hals require it, but many of them do.
Flags: needinfo?(mwu)
(In reply to Michael Wu [:mwu] from comment #30)
>
> Yeah we have it on a number of ports. Not all camera hals require it, but
> many of them do.

Okay, I see it in extract-files.sh for:
- hamachi/buri - see comment 0; WFM in comment 17
- helix
- leo - see comment 8; WFM in comment 17

And not for:
- crespo
- galaxys2
- inari
- keon
- m4
- maguro
- otoro
- panda
- unagi - see comment 2, comment 5, and comment 8, WFM in comments 13, 14, and 17

Looks like it's gone away in all of the reported platforms. Thanks, everyone.

Comment 32

5 years ago
The above issue has been resolved per comment 26 and comment 31.
verifying this bug as fixed.

Current camera black screen issue is being tracked on bug 880780.
Status: RESOLVED → VERIFIED
There doesn't seem to be any resolving code here o_O
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.