Closed Bug 879335 Opened 6 years ago Closed 6 years ago

Remove WebRTC + permissions from Firefox 23

Categories

(Firefox for Android :: General, defect)

23 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox23 + verified disabled
firefox24 + ---
fennec 23+ ---

People

(Reporter: gcp, Assigned: gcp)

References

(Blocks 1 open bug)

Details

(Whiteboard: [WebRTC][android-webrtc+])

Attachments

(2 files, 1 obsolete file)

Firefox 23 currently contains very preliminary WebRTC support, and adds the permissions required for that. As the support is a bit too rudimentary to be very useful even for most developers, and we prefer to group new permissions being added to Fennec:

1) Disable WebRTC building on Firefox 23.
2) Remove the WebRTC permissions from the Android Manifest (prolly automatic as a result of (1), but let's check!)
tracking-fennec: --- → ?
Tested on try, verified resulting APK no longer requests the new permissions.
Attachment #758714 - Attachment is patch: true
Attachment #758714 - Flags: review?(blassey.bugs)
Comment on attachment 758714 [details] [diff] [review]
Patch 1. Disable WebRTC building.

Review of attachment 758714 [details] [diff] [review]:
-----------------------------------------------------------------

to be landed on 23 only
Attachment #758714 - Flags: review?(blassey.bugs) → review+
Assignee: nobody → gpascutto
tracking-fennec: ? → 23+
Whiteboard: [WebRTC][android-webrtc+]
Comment on attachment 758714 [details] [diff] [review]
Patch 1. Disable WebRTC building.

This patch disables WebRTC on Firefox 23 - too much bugs remaining, too late to land the permissions and notification UI for it.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): WebRTC for Android
User impact if declined: Need to manually approve Firefox update in Google Play, for a feature that is mostly unusable.
Testing completed (on m-c, etc.): Local only. Build config change.
Risk to taking this patch (and alternatives if risky): Failure to disable a feature at build time.
String or IDL/UUID changes made by this patch: None.
Attachment #758714 - Flags: approval-mozilla-aurora?
Attachment #758714 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Tracking, in case we have to disable later on for Fx24 as well)
I'm assuming the landing in comment 5 means we close this, as this is Aurora-only bug and does not require a central landing.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Backed out:
https://hg.mozilla.org/releases/mozilla-aurora/rev/27bcde94e2ee

It looks like this needs to land together with a backout of bug 867778 on Aurora.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Bug 862883 also needs to be backed out.
(In reply to Gian-Carlo Pascutto (:gcp) from comment #8)
> Bug 862883 also needs to be backed out.

Either that or we could just turn the mochitests off for Fx23 in the android exclude list. In fact, doing the exclude list change would probably be easier.
>In fact, doing the exclude list change would probably be easier.

Can you make a patch for this?
Comment on attachment 764533 [details] [diff] [review]
Disable WebRTC Automation on FxAndroid 23

Review of attachment 764533 [details] [diff] [review]:
-----------------------------------------------------------------

Try running coming shortly.
Attachment #764533 - Flags: review?(hskupin)
Comment on attachment 764533 [details] [diff] [review]
Disable WebRTC Automation on FxAndroid 23

Screwed up here. Let me pull my tree correctly this time...
Attachment #764533 - Attachment is obsolete: true
Attachment #764533 - Flags: review?(hskupin)
Attachment #764547 - Flags: review?(hskupin)
Comment on attachment 764547 [details] [diff] [review]
Disable WebRTC Automation on FxAndroid 23

Review of attachment 764547 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me but please come up with a try server run, which proves that all is fine and we do not miss something. Thanks.
Attachment #764547 - Flags: review?(hskupin) → review+
gcp - patch is ready to go. Do you want to kick off a try run with your patch and my patch to see if we're green?
Flags: needinfo?(gpascutto)
Actually disregard. I can probably do it.
Flags: needinfo?(gpascutto)
Comment on attachment 764547 [details] [diff] [review]
Disable WebRTC Automation on FxAndroid 23

[Approval Request Comment]
Bug caused by (feature/regressing bug #): WebRTC on FxAndroid on 23.
User impact if declined: Won't be able to turn off WebRTC on FxAndroid on 23, resulting in issues mentioned in other approval request.
Testing completed (on m-c, etc.): Buildbot run kicked off, if green, should indicate we're okay.
Risk to taking this patch (and alternatives if risky): None - this is a test only patch.
String or IDL/UUID changes made by this patch: None
Attachment #764547 - Flags: approval-mozilla-aurora?
(In reply to Jason Smith [:jsmith] from comment #19)
> Risk to taking this patch (and alternatives if risky): None - this is a test
> only patch.

This patch doesn't need approval to get landed on aurora. Just include a=test-only in the commit message and get it landed.
Attachment #764547 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Try run is green across the board. Let's land this on Aurora
Keywords: checkin-needed
Keywords: checkin-needed
Keywords: verifyme
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.