Closed Bug 87939 Opened 21 years ago Closed 21 years ago

Sidebar region does not change when non-default region is selected

Categories

(SeaMonkey :: Sidebar, defect, P2)

x86
Windows ME

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: jonrubin, Assigned: rchen)

References

Details

(Keywords: intl, relnote)

Tested on 6.1b build using WinMe-Ja.

Steps:
1) Start browser (English or Japanese version).
2) Download and install a new region pack if none but the defaults are available.
3) Select the new region pack in View>Language/Region.  
4) Close and restart browser.  The region changes, as can be seen by the
Netscape page that opens when clicking on throbber, but the Sidebar is still set
to the default region.



------- Additional Comments From jonrubin@netscape.com 2001-06-22 21:27:21 ----

Should the fix for Bugzilla 52930 fix this?



------- Additional Comments From rchen@netscape.com 2001-06-25 13:30:36 ----

Region pack issue.



------- Additional Comments From jonrubin@netscape.com 2001-06-25 16:13:39 ----

cc nhotta



------- Additional Comments From jonrubin@netscape.com 2001-06-25 17:54:45 ----

Andreas, if no one objects, can you move this to Bugzilla?  Thanks.



------- Additional Comments From nhotta@netscape.com 2001-06-25 17:59:10 ----

I think bugzilla 80230 patch fixes this problem.





------- Bug moved to this database by andreasb@netscape.com 2001-06-26 18:35 -------

This bug previously known as bug 6829 at http://bugscape.netscape.com/
http://bugscape.netscape.com/show_bug.cgi?id=6829
Originally filed under the Browser product and Localization-JA component.
Ftang - Should this get a nsBranch?
Component: Browser-General → Sidebar
Keywords: intl, nsbeta1
Marking as dependent on bug 80230 according to nhotta's comment, please remove
dependency if this is not the case.
Depends on: 80230
Fix for bug 80230 was checked in to the branch on 6/29, please test this again
with the latest branch build.
Content switch by menu does not work until bug 87535 is checked in. So, please
try content switch by preference dialog to verify this bug.
Jon, did you get a chance to try this?
This seems to be a dup of 87938. -> rchen
Assignee: tao → rchen
Status: NEW → UNCONFIRMED
Blocks: 62177
Oops, after taking a close look. It's a different problem.

This is by design: sidebar panels and bookmarks will not change when you switch
the region via "View" or "Prefs" dialog. The rationale is that they are
profile-bound setting and should not be altered once they are copied into the
user's profile directory during creation.

->INVALID
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → INVALID
No longer blocks: 62177
Jaime, we probably need to document (in release notes?) that sidebar panels and
bookmarks will not be changed when switching region, if this isn't already
documented.
Jaime, do you know if this is already documented?
Yes, this is documented in Tao's spec, but we should mark relnote, so that
rudman's tema picks this up.

Adding lbaliman, as she reviews the release notes for GCT PMs.
Jaime, do you mean that this should be reopened and reassigned until the release
notes are reviewed?
Removing lbaliman from cc-list.  Not tasked with reviewing release notes.
Adding keyword relnote and relnoteRTM for now, please clean up keywords if you
feel that this doesn't need to be in the release notes.
Keywords: relnote, relnoteRTM
added to the rel.note tracking bug
Verified as added to relnote tracking bug 90577.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.