Closed Bug 879404 Opened 8 years ago Closed 1 year ago

Use TimeStamp instead of PRTime in nsJSContext

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1580883

People

(Reporter: mccr8, Unassigned)

Details

Attachments

(2 files)

Apparently PRTime doesn't guarantee monotonicity (ie that time always moves forward), so this can end up feeding negative durations for CCs to the profiler, which results in junky output.  I think TimeStamp doesn't have that problem, so we should convert to it, at least for the CC logging stuff.
Assignee: nobody → continuation
Andrew: are these TimeStamp patches still relevant for CC logging?
Flags: needinfo?(continuation)
I've converted some of the uses of PRTime in another patch, but I guess we could still convert the rest.
Flags: needinfo?(continuation)
One thing to watch out for here is the generation of the JSON for the GC takes a PRTime::Now() argument thing.  That probably needs to get converted to taking a time delta computed from TimeStamp in nsJSEnvironment.
Assignee: continuation → nobody
Priority: -- → P5
Component: DOM → DOM: Core & HTML
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1580883
You need to log in before you can comment on or make changes to this bug.