Report job times on individual slave pages in PST

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: armenzg, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [slavehealth])

(Reporter)

Description

5 years ago
If I load this up:
https://secure.pub.build.mozilla.org/builddata/reports/slave_health/slavetype.html?class=test&type=t-xp32-ix

The systems says that these machines have not taken a job for a while:
t-xp32-ix-030 11:33:44
t-xp32-ix-120  8:35:15
but if I load their individual pages I get a different story:
https://secure.pub.build.mozilla.org/builddata/reports/slave_health/slave.html?class=test&type=t-xp32-ix&name=t-xp32-ix-030
https://secure.pub.build.mozilla.org/builddata/reports/slave_health/slave.html?class=test&type=t-xp32-ix&name=t-xp32-ix-120

http://cl.ly/PQWX
The last job is from a bit ago rather than 11 hours ago:
Windows XP 32-bit mozilla-inbound opt test mochitest-1	Tue Jun 4 10:24:57 2013	Tue Jun 4 10:43:35 2013	00:18:38
(Assignee)

Comment 1

5 years ago
The times on the individual slave page are in GMT, so it *looks* like they've completed jobs more recently
Assignee: nobody → coop
OS: Mac OS X → Linux
Priority: -- → P3
Summary: Slave health report misreports two slaves → Report job times on individual slave pages in PST
Whiteboard: [slavehealth]
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2
(Assignee)

Comment 2

5 years ago
It turns out that working with dates in JS is hard, but I have the job times reporting in PDT now.

https://hg.mozilla.org/users/coop_mozilla.com/slave_health/rev/a739ceca3ecb
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.