Closed Bug 879500 Opened 7 years ago Closed 6 years ago

Subviews should resize to fit contents

Categories

(Firefox :: Toolbars and Customization, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: Gijs, Assigned: tnikkel)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:M8][Australis:P2])

(possibly related to bug 878546)

STR:

1. Remove lots of things from the panel.
2. Open the help/bookmarks/history subview

ER:
You can see + click all the items.

AR:
You cannot see + click all the items.
Note it's also true the other way : there is a lot of lost space when your default panel is big and you open the help subview for example.
Taking this one to Australis M7
Whiteboard: [Australis:M?] → [Australis:M7]
Assignee: nobody → gijskruitbosch+bugs
Removing the items from M7 that do not block us from landing on m-c.
Whiteboard: [Australis:M7] → [Australis:M?]
This is caused by the panel getting a height attribute set somehow. Removing that seems to make this work correctly. Honestly not sure how that's happening from looking at our code. It might be the panel setting it?
Can anyone still reproduce this on Windows? I still see this on OS X, but mconley said it's gone on Windows.
OS: All → Mac OS X
Hardware: All → x86_64
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P2]
So this is still not working quite correctly on OS X (possibly retina-only?) because panels get auto-resized when OS X moves stuff around. See also eg. bug 852775. This is also causing a slight centering issue when the parent window is flush with the right window edge - the panel gets moved onscreen and becomes a bit narrower, leading to a larger right margin than left margin (as the panelview gets slightly cut off).
(In reply to :Gijs Kruitbosch from comment #6)
> So this is still not working quite correctly on OS X (possibly retina-only?)
> because panels get auto-resized when OS X moves stuff around. See also eg.
> bug 852775. This is also causing a slight centering issue when the parent
> window is flush with the right window edge - the panel gets moved onscreen
> and becomes a bit narrower, leading to a larger right margin than left
> margin (as the panelview gets slightly cut off).

Mark pointed out in bug 874792 that this is possibly incorrect. I've been trying to debug it on a debug build to see what's going on, but without much success (in part because switching to your debugger fires new events and makes the panel not appear and all sorts of funny things like that - I guess I should just dump debug, but I haven't had the time to do that yet).

I *have* noticed that sometimes the panel is cut off, but when I set noautohide to do some DOMI inspecting on it it seemed to just be moved slightly, rather than resized? I haven't managed to figure out why this is, and/or if it's related to the noautohide or something else.
Status: NEW → ASSIGNED
Depends on: 874792
I can't reproduce this anymore, and am fairly sure this was fixed by bug 892994.
Depends on: 892994
No longer depends on: 874792
Whiteboard: [Australis:M?][Australis:P2] → [Australis:M8][Australis:P2][fixed-in-ux]
Assignee: gijskruitbosch+bugs → tnikkel
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M8][Australis:P2][fixed-in-ux] → [Australis:M8][Australis:P2]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.