All users were logged out of Bugzilla on October 13th, 2018

[traceback] Link to minimanifest tracebacks

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: krupa.mozbugs, Assigned: cvan)

Tracking

({regression})

2013-06-06
regression
Points:
---

Details

(URL)

(Assignee)

Comment 1

5 years ago
genericpath in getsize
Task mkt.webapps.tasks.update_cached_manifests[3bd96099-da07-4c70-8d0d-211622f3b7a3] raised exception: OSError(2, 'No such file or directory')

Stacktrace (most recent call last):

  File "celery/task/trace.py", line 228, in trace_task
    R = retval = fun(*args, **kwargs)
  File "newrelic/api/object_wrapper.py", line 216, in __call__
    self._nr_instance, args, kwargs)
  File "newrelic/hooks/application_celery.py", line 62, in wrapper
    return wrapped(*args, **kwargs)
  File "celery/task/trace.py", line 415, in __protected_call__
    return self.run(*args, **kwargs)
  File "nuggets/celeryutils.py", line 35, in wrapped
    return fun(*args, **kw)
  File "mkt/webapps/tasks.py", line 224, in update_cached_manifests
    webapp.get_cached_manifest(force=True)
  File "mkt/webapps/models.py", line 709, in get_cached_manifest
    'size': storage.size(file_obj.signed_file_path),
  File "django/core/files/storage.py", line 250, in size
    return os.path.getsize(self.path(name))
  File "python2.6/genericpath.py", line 49, in getsize
    return os.stat(filename).st_size
Assignee: nobody → cvan
Hmm, it's true, the signed file isn't there. Yet the file status in the database for this version of the marketplace app is set to PUBLIC. Perhaps signing failed and we didn't roll back properly?

The version also doesn't have a reviewed date. So something went wrong here. I don't see a signing attempt in the logs.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

5 years ago
Try https://marketplace-dev.allizom.org/app/131c0de6-27fb-41b2-8ad3-1d428b234c85/manifest.webapp
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

5 years ago
(In reply to krupa raj 82[:krupa] from comment #4)
> Try
> https://marketplace-dev.allizom.org/app/131c0de6-27fb-41b2-8ad3-1d428b234c85/
> manifest.webapp

SInce this is not a signed packaged app, I will file a separate bug for this.
(Reporter)

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.