Hide the menubar by default on XP.

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M-])

(Reporter)

Description

6 years ago
(Filed from Australis tabs ui-review #1)

We should hide the menubar by default on XP.
Assignee: nobody → mnoorenberghe+bmo
Blocks: 870032
No longer blocks: 732583
Status: NEW → ASSIGNED
Component: Theme → Menus
Whiteboard: [Australis:M?] → [Australis:M7]
Enabling the Firefox button was previous wontfixed in bug 612348, the rationale in bug 612348 comment 2 appears to apply to this bug as well.
I believe the thinking has changed since then in that we want to deliver a more modern experience for those who are stuck on XP. Stephen, can you confirm that you want to proceed with this despite the previous WONTFIX?
Flags: needinfo?(shorlander)
Removing the items from M7 that do not block us from landing on m-c.
Whiteboard: [Australis:M7] → [Australis:M?]
After seeing a large proportion of users in the wild with their menubars visible, I think we need more data to know whether those users can adapt to having no menubar by default.
Assignee: mnoorenberghe+bmo → nobody
Status: ASSIGNED → UNCONFIRMED
Ever confirmed: false
(Reporter)

Updated

6 years ago
Whiteboard: [Australis:M?] → [Australis:M-]
(In reply to Matthew N. [:MattN] from comment #4)
> After seeing a large proportion of users in the wild with their menubars
> visible, I think we need more data to know whether those users can adapt to
> having no menubar by default.

The users that we saw during the Australis user testing were on a variety of operating systems, not just XP. If we believe that the menubar is important for users, then we would need to make it visible (or at least easier to enable) on all platforms.

We also saw that many users found the new Australis menu to be easier to find and thus use compared to the orange Firefox menu.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Jared Wein [:jaws] from comment #5)
> If we believe that the menubar is important for users,

I don't think anybody made such a bold statement. The concern is that the menubar is particularly important for users on XP, because it's pretty much a convention on that OS.
Whiteboard: [Australis:M-] → [Australis:M-][Australis:P?]
Whiteboard: [Australis:M-][Australis:P?] → [Australis:M-][Australis:P4]
Whiteboard: [Australis:M-][Australis:P4] → [Australis:M-]
Is this still relevant even though XP support will cease after 52 ESR?
https://blog.mozilla.org/futurereleases/2016/12/23/firefox-support-for-xp-and-vista/
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Flags: needinfo?(shorlander)
You need to log in before you can comment on or make changes to this bug.