Black/blank window & hang under OS X if hide TB while sending email [Mac]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: cbmarkwardt+bugzilla, Unassigned)

Tracking

(Blocks: 1 bug, {hang})

22 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:?])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 758373 [details]
Example of black/blank compose and sending window as described in text.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

OS X 10.8.3 TB 22.0
1. Compose outgoing email message (content is unimportant) with subject
2. Click "Send"
3. Immediately Command-H to hide TB before send has completed
4. Wait for send to complete and unhide TB.



Actual results:

A. Compose window is still present, but title is "Write: (no subject)" and window contents are completely black (i.e. no window content)
B. "Sending Message" status window is still present even though message has been sent and delivered.
C. If you click the red close button, TB crashes often hard (not always).  Upon restart of TB, it does prompt for any crash info.

None of this happens if TB remains unhidden during email send.

This appears to be a regression from previous version before TB 22.



Expected results:

i. Compose window should be deallocated when send is complete
ii. "Sending Message" window should be deallocated when send is complete
iii. TB shouldn't crash when closing windows.
(Reporter)

Comment 1

6 years ago
Changed component to "Message Compose Window"
Component: Untriaged → Message Compose Window
Anything in tools | error console?

Does crash or bad compose window occur if thunderbird is started in safe mode?
 ref: https://support.mozillamessaging.com/en-US/kb/safe-mode
(Reporter)

Comment 3

6 years ago
Nothing appears in in the error console. 

The "Restart with Add-ons disabled" menu item was grayed out when I tried.  I'll try the option-start method when I get back to the affected computer.
(Reporter)

Comment 4

6 years ago
"Restart with Add-ons disabled" is non-functional.  Option-start is also non-functional.

I disabled all of my extensions by hand, and the black/blank compose window bug still occurs.
So these two steps 
3. Immediately Command-H to hide TB before send has completed
4. Wait for send to complete and unhide TB.
are what make the difference.

Is this the recycled compose window.
(In reply to Wayne Mery (:wsmwk) from comment #5)
> Is this the recycled compose window.

FYI. bug 866223 was fixed in Tb 22 in adition to Tb 23 and later. However, Tb 22 is in Release Candidate state(latest is build2), so different build cycle from ordinal daily may be applied(Earlybird : Tb 23, Aurora/comm-central : Tb 24). It depends on both Tb build used by bug opener and mail.compose.max_recycled_windows setting used by bug opener.
(Reporter)

Comment 7

6 years ago
My current setting of mail.compose.max_recycled_windows is 1.

If I change the value to 0, then this bug does not appear!

Updated

6 years ago
Whiteboard: [regression:?]
(Reporter)

Comment 8

6 years ago
Same bug occurs in TB 23.0.

Updated

6 years ago
Blocks: 482756
Severity: normal → critical
Keywords: crash
Mitra, can you reproduce per comment 7?
Flags: needinfo?(mitra_lists)
Keywords: crash → hang
Summary: Black/blank Window & Crash under OS X if hide TB while sending email → Black/blank window & hang under OS X if hide TB while sending email [Mac]

Comment 10

5 years ago
I am not able to repeat this, 

I've been running for a long time with mail.compose.max_recycled_windows is 0 because of bug #917027 (which i notice is reported fixed) so I haven't seen this bug before. 

I set it back to 1 and was unable to repeat this bug.
Flags: needinfo?(mitra_lists)
(Reporter)

Comment 11

5 years ago
I attempted to reproduce this on TB 26.0, but I couldn't.  I tried it four times and one of the times, after I unhid TB, I could see a blank window for about 0.5 seconds, but it vanished shortly thereafter.

So overall, as the original reporter, I would say this bug is fixed in TB 26.0.
Thanks Craig!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.