Closed Bug 879672 Opened 9 years ago Closed 9 years ago

[MediaEncoder] Connect MediaStreamAudioDestinationNode::MediaStream with Audio recording API

Categories

(Core :: Web Audio, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 896353

People

(Reporter: u459114, Assigned: jwwang)

References

Details

(Whiteboard: [blocking-webaudio-])

MediaStreamAudioDestinationNode is a destination node in WebAudio. MediaStreamAudioDestinationNode aggregate a media stream object, which can be an input of Media recorder. MediaRecoder should be able to generate encode blob from MediaStreamAudioDestinationNode::MediaStream correctly.
Summary: [MediaRecorder] Connect MediaStreamAudioDestinationNode::MediaStream with MediaRecorder → [MediaEncoder] Connect MediaStreamAudioDestinationNode::MediaStream with Audio recording API
Hmm, I'm not sure if I understand what this bug is about.  Could you please explain what you need a bit more?  Thanks!
Sure.
After Bug 865257 complete, we could assign a MediaStreamAudioDestinationNode node as desination node in web audio graph. sample code looks like:

var node = atx.createMediaStreamDestination();
var mr = new MediaRecorder(node.stream);

By taking MediaStreamAudioDestinationNode.stream as input of MediaRecoder, we are able to record and encode audio stream. Apps, such as audio mixer, need this kind of feature.
I see.  I was not aware that we have an implementation of MediaRecorder.  Has it landed yet?  Or is there a bug for that?
Bug 803414 - MediaRecorder WebAPI. To support this API, we need to have native media encoding framework.
Bug 879688 - which is the meta issue for media encoder.
Component: Video/Audio → Web Audio
Can you please tell us more about what needs to happen in this bug?
Flags: needinfo?(cku)
Thanks for reminding.
If we create a new MediaRecorder and boundle that MediaRecorder with a MediaStreamAudioDestinationNode::MediaStream, it should be able to get encoded audio samples from onDataAvailable function or manually request by mr::requestData. 

JW,
Please help to verify this issue.
Assignee: nobody → jwwang
Flags: needinfo?(cku)
It is duplicate of Bug 896353.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 896353
Whiteboard: [blocking-webaudio-]
You need to log in before you can comment on or make changes to this bug.