If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

style property is missing from XML elements and XUL elements in JS objects, but present in HTML

VERIFIED DUPLICATE of bug 7639

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 7639
19 years ago
9 years ago

People

(Reporter: Josh Gough, Assigned: Eric Vaughan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Using XML and XUL elements together with html namespaced elements, I have been
unable to modify the CSS properties of either XUL or custom XML tags via
javascript because the style property is missing. Both of these marvelously obey
the css styles defined in their stylesheets, and I can even create new nodes
that obey the styles.

These are the properties that html elements show:

accessKey,attributes,childNodes,className,dir,disabled,firstChild,form,id,lang,lastChild,name,nextSibling,nodeName,nodeType,nodeValue,ownerDocument,parentNode,previousSibling,style,tabIndex,tagName,title,type,value

The xul or xml elements return this:

attributes,childNodes,firstChild,lastChild,nextSibling,nodeName,nodeType,nodeValue,ownerDocument,parentNode,previousSibling,resource,tagName

I figured that any element that used CSS should have the style property
exposed to the javascript objects.

I am using M6 built from source on Linux 2.0.36

I put a few files at http://131.96.115.58/~exv/xul/ which demonstrate
some what does work (adding elements that obey the css), and shows
these properties being printed out.

-Josh Gough

Updated

19 years ago
Assignee: peterl → trudelle
Component: Style System → XUL

Comment 1

19 years ago
XML elements should *NOT* have the style property. The style property is a
reflection of the "style" attribute which does not mean anything special in XML,
only in HTML.

Whether or not the style property should be exposed from XUL is another matter
(since it DOES have a "style" attribute), I'll let the XUL guys figure that one
out.

Updated

19 years ago
Assignee: trudelle → evaughan
Target Milestone: M9

Comment 2

19 years ago
assigning to evaughan as p3 for m9

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
Dup of 7639.


*** This bug has been marked as a duplicate of 7639 ***

Updated

19 years ago
QA Contact: chrisd → ckritzer

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Verified DUPLICATE of 7639 in build 1999071309 Linux6

Comment 5

18 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: ckritzer → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.