[SMS] Proper implementation of phone number format recognition in SMS application (Eg using libphonenumber)

RESOLVED INVALID

Status

Firefox OS
Gaia::SMS
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: Leo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
1. Title: Proper implementation of phone number format recognition in SMS application (Eg using libphonenumber)
2. Precondition: SMS app should be working
3. Tester's Action:(1) Open the SMS application
         (2) Receive phone number with  valid area code (Ex:   11, 16, 19, 41...)                                
4. Detailed Symptom (ENG.) :Some  phone numbers are not recognized 
5. Expected: Phone numbers with all the formats should be recognized
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train: Reproduced on v1-train and master
8. Gaia Revision:  25cff35fd9f87b1f3936a5fa7388a3bb5b460034
9. Personal email id: sasikala.paruchuri8@gmail.com
(Reporter)

Comment 1

5 years ago
Can we implement these features using the libphonenumber which is having open source js implemantation.
https://code.google.com/p/libphonenumber/

Comment 2

5 years ago
This would be really useful for the "format as you type" part in dialer/sms/etc wherever you might have to type a phone number
I just switched to a Firefox OS device as my primary phone and imported all of my contacts from Google. I've been receiving many SMS/MMS messages from numbers that exist in my contacts but the messaging app hasn't been showing me the contact names because the format of the phone numbers in my contacts list is not international format.

We could fix this either by fixing this bug, or the related bug 1204621
Hi Tim, we should definitely match phone numbers even if they're in their national format.

However we have bug 1114525. This appears only if you imported your contacts while in roaming condition (or maybe if you had no SIM yet). Can you confirm this?

This bug is very old, I'll close it as it's obsolete now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.